v4.06 Application Released for Windows x64 for OpenCL
log in

Advanced search

Message boards : News : v4.06 Application Released for Windows x64 for OpenCL

Author Message
Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 16445 - Posted: 9 May 2013, 22:15:48 UTC

Version 4.06 for Windows Vista/7/8 64-bit operating systems with AMD OpenCL GPUs has been released for collatz, mini_collatz, and solo_collatz applications. This release should fix the issues people with HD 7xxx and later GPUs and/or recent AMD Catalyst 13.x drivers have been having. If you continue to have problems, please respond to this thread via the message board.

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 16446 - Posted: 9 May 2013, 22:29:56 UTC

Since I know someone will ask... The "fix" was to disable OpenCL compiler optimization (-cl-opt-disable) which means it is really more of a hack than a fix. The app now works on my HD 7790, but it may work a little slower for those who were not having prior issues. I have sent the OpenCL kernel code to AMD in hopes they will be able to duplicate the issue and fix it in some future version. (One can always dream, right?)

Thomas
Send message
Joined: 16 Apr 10
Posts: 1
Credit: 336,191,748
RAC: 0
Message 16451 - Posted: 10 May 2013, 10:50:50 UTC

If i check the load of my GPU, its only about 25%. With version 4.05 and with my config-File it was about 90%. Ist there ans configuration hat i can do to get the load back to this 90%

Kwartet!
Send message
Joined: 21 Nov 12
Posts: 6
Credit: 322,984,444
RAC: 400,136
Message 16452 - Posted: 10 May 2013, 12:00:20 UTC - in response to Message 16446.
Last modified: 10 May 2013, 12:08:35 UTC

4.06 is running faster than 4.05. Average GPU time was around 11.000 secs, new GPU time 6.000 secs. GPU activity went down too.

I posted about this in the 'ByeByeWingman' thread (http://boinc.thesonntags.com/collatz/forum_thread.php?id=997).

EDIT Oh, Thomas, run multiple instances.
I use this app_config.xml in my collatz data directory:

<app_config>
<app><name>solo_collatz</name>
<max_concurrent>2</max_concurrent>
<gpu_versions>
<gpu_usage>0.5</gpu_usage>
<cpu_usage>0.02</cpu_usage>
</gpu_versions></app>
</app_config>

And mind you: save as ANSI. When I saved as UTF, BOINC saw the file but ignored its contents.

Cai0407@chem@lounge
Send message
Joined: 29 Aug 11
Posts: 1
Credit: 61,309,640
RAC: 74,341
Message 16455 - Posted: 10 May 2013, 15:22:18 UTC

4.06 seems to work fine with Radeon HD7870 / Catalyst 13.4.
computer 125741

I've tested multithread calculation (2 threads).
One has finished successfully.
The other has been aborted with error "GPU steps do not match CPU steps", however, this is different from that of 4.05 or 4.03 "Unhandled Exception Detected".
finished task: task 140127986
aborted task: task 140127467

Juergen
Send message
Joined: 29 May 12
Posts: 4
Credit: 10,925,841
RAC: 47,645
Message 16456 - Posted: 10 May 2013, 16:40:21 UTC

The collatz and mini_collatz work fine on my 5870, thanks for the update.

But i get a error with the solo_collatz:
Error: GPU steps do not match CPU steps. Workunit processing has been aborted.

Chris Skull
Send message
Joined: 23 Dec 10
Posts: 1
Credit: 21,137,438
RAC: 0
Message 16457 - Posted: 11 May 2013, 8:04:37 UTC - in response to Message 16456.

Hello,

with the new app v 4.03 the units take 2x up to 3x as long as with 2.09.
How can i manage my client to use the old app ?

Greetz
Chris
____________

Profile mikey
Avatar
Send message
Joined: 11 Aug 09
Posts: 3242
Credit: 1,692,811,854
RAC: 5,553,064
Message 16458 - Posted: 11 May 2013, 11:02:50 UTC - in response to Message 16452.

4.06 is running faster than 4.05. Average GPU time was around 11.000 secs, new GPU time 6.000 secs. GPU activity went down too.

I posted about this in the 'ByeByeWingman' thread (http://boinc.thesonntags.com/collatz/forum_thread.php?id=997).

EDIT Oh, Thomas, run multiple instances.
I use this app_config.xml in my collatz data directory:

<app_config>
<app><name>solo_collatz</name>
<max_concurrent>2</max_concurrent>
<gpu_versions>
<gpu_usage>0.5</gpu_usage>
<cpu_usage>0.02</cpu_usage>
</gpu_versions></app>
</app_config>

And mind you: save as ANSI. When I saved as UTF, BOINC saw the file but ignored its contents.


One thing the max_concurrent line should INCLUDE the cpu cores you are using as well as the gpu's you are using. It is BOTH not one or the other. So if you are running 2 gpu units that would be 2 but then adding in a quad core cpu would mean the number should be 6.

I save my app_config files as text type files using the xml extension in NOTEPAD in Windows. If you use a word processing program it can cause the file to be unreadable.

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 16459 - Posted: 11 May 2013, 14:12:37 UTC - in response to Message 16457.

Hello,

with the new app v 4.03 the units take 2x up to 3x as long as with 2.09.
How can i manage my client to use the old app ?

Greetz
Chris


It can be installed as an anonymous application (optimized application). A full description can be found at [URL]GPU steps do not match CPU steps[/URL]

The 2.09 version can be downloaded from http://boinc.thesonntags.com/collatz/power_apps.php

At some point, AMD will drop ALL support for Brook+/CAL applications and only the OpenCL versions will work. They have been saying that for a while now so it is hard to tell when or if that will ever happen.

VictordeHollander
Send message
Joined: 13 Jan 11
Posts: 3
Credit: 70,833,020
RAC: 0
Message 16464 - Posted: 13 May 2013, 13:07:29 UTC

At the moment I'm getting both v4.03 and v4.06 tasks on my 7950. The v4.06 app is much faster (1900 sec vs 1350 sec). Is it possible to only receive v4.06 tasks for this PC, or will v4.03 be phased out in the near future?

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 16466 - Posted: 13 May 2013, 15:42:08 UTC - in response to Message 16464.

At the moment I'm getting both v4.03 and v4.06 tasks on my 7950. The v4.06 app is much faster (1900 sec vs 1350 sec). Is it possible to only receive v4.06 tasks for this PC, or will v4.03 be phased out in the near future?



You would think BOINC would send out the latest version only. Duh! That would make sense! I'll deprecate the 4.03 app so only 4.06 will be sent going forward.

VictordeHollander
Send message
Joined: 13 Jan 11
Posts: 3
Credit: 70,833,020
RAC: 0
Message 16467 - Posted: 13 May 2013, 16:33:49 UTC

Thanks, it seems to be fixed now.

Kombizahl
Send message
Joined: 29 Sep 09
Posts: 12
Credit: 158,620,174
RAC: 204
Message 16469 - Posted: 13 May 2013, 20:39:12 UTC

I see that my new mini collatz run at mom 1h 40min and the progressbar shows less more than 50%.Is that normal for now?
Greetings

Stick
Send message
Joined: 30 Apr 10
Posts: 20
Credit: 10,894,804
RAC: 53,478
Message 16474 - Posted: 14 May 2013, 1:59:03 UTC

I have a WU that's running way too long with solo_collatz v4.06 (opencl_ati_100). That is, it's only 7.5% complete after 35 hours. I am guessing it's the app, since my usual completion time with collatz v2.09 (ati13ati) is about 17 hours and my only other WU's with solo crashed immediately with v4.05. I will probably abort it but, before I do, is anyone interested in any data I could provide to help with debugging?

Profile mikey
Avatar
Send message
Joined: 11 Aug 09
Posts: 3242
Credit: 1,692,811,854
RAC: 5,553,064
Message 16475 - Posted: 14 May 2013, 11:09:45 UTC - in response to Message 16474.

I have a WU that's running way too long with solo_collatz v4.06 (opencl_ati_100). That is, it's only 7.5% complete after 35 hours. I am guessing it's the app, since my usual completion time with collatz v2.09 (ati13ati) is about 17 hours and my only other WU's with solo crashed immediately with v4.05. I will probably abort it but, before I do, is anyone interested in any data I could provide to help with debugging?


Try suspending Collatz and then after a 5 count resume it again and see if the slow unit doesn't start back up again.

Stick
Send message
Joined: 30 Apr 10
Posts: 20
Credit: 10,894,804
RAC: 53,478
Message 16476 - Posted: 14 May 2013, 11:20:42 UTC - in response to Message 16475.

I have a WU that's running way too long with solo_collatz v4.06 (opencl_ati_100). That is, it's only 7.5% complete after 35 hours. I am guessing it's the app, since my usual completion time with collatz v2.09 (ati13ati) is about 17 hours and my only other WU's with solo crashed immediately with v4.05. I will probably abort it but, before I do, is anyone interested in any data I could provide to help with debugging?


Try suspending Collatz and then after a 5 count resume it again and see if the slow unit doesn't start back up again.

I had tried suspending/resuming several times before posting. That's not the problem. It's not stuck, it's just progressing very, very slowly.

VictordeHollander
Send message
Joined: 13 Jan 11
Posts: 3
Credit: 70,833,020
RAC: 0
Message 16484 - Posted: 14 May 2013, 23:14:25 UTC

Unusually high credit tasks!!

I've got a few tasks that received unusually high credits for the work done. These tasks should get about ~4.000 credits each, but instead got 11.000+. This doesn't seem normal and I don't have an explanation for them, although it would seem the 'problem' started with the introduction of the v4.06 app.

http://boinc.thesonntags.com/collatz/workunit.php?wuid=61229446 11,326.61 credits
http://boinc.thesonntags.com/collatz/workunit.php?wuid=61219919 11,945.68 credits

And this is really a weird one, my computer gets 12,320.62 and the other the normal 4,106.87:
http://boinc.thesonntags.com/collatz/workunit.php?wuid=61181617


Post to thread

Message boards : News : v4.06 Application Released for Windows x64 for OpenCL


Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.