Issue running collatz 4.04 (cuda50)
log in

Advanced search

Message boards : Unix/Linux : Issue running collatz 4.04 (cuda50)

Author Message
mrspooky
Send message
Joined: 14 Aug 11
Posts: 3
Credit: 16,058,341
RAC: 0
Message 16485 - Posted: 15 May 2013, 3:52:36 UTC

Hi,

I'm having issues using collatz 4.04 cuda.
Every wu that I ran aborted with a floating point exception.
This is one of my failed tasks.

I put a strace here http://pastebin.com/1sJmqzdk (if that helps).

I'm using debian unstable now, but I have tested on debian 7 stable, linux mint 14, ubuntu 13, using the latest cuda-toolkit, and I saw the same exception occuring always.

Another point is that I can run the same app on windows without problems, and I'm testing einstein@home without any problems, at least for now.

Someone experienced this?

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 2
Message 16498 - Posted: 16 May 2013, 18:15:31 UTC

I'd be real interested to know if anyone else with a compute 3.0 device has had success. My 670M is only compute 2.1. The app uses the following to compile the CUDA code:

nvcc -gencode arch=compute_10,code=sm_10 -gencode arch=compute_11,code=sm_11 -gencode arch=compute_12,code=sm_12 -gencode arch=compute_13,code=sm_13 -gencode arch=compute_20,code=sm_20 -gencode arch=compute_20,code=sm_21 -gencode arch=compute_30,code=sm_30 -gencode arch=compute_35,code=sm_35 -m 64 -c collatz.cu -o $(IntDir)\collatz.o --ptxas-options=-v --optimize 3

As I understand it, that should produce GPU specific code for compute capability 1.0, 1.1, 1.2, 1.3, 2.0, 2.1, 3.0, and 3.5 devices and each device __should__ run the appropriate version automatically.

If you have experience with using app_info.xml files, I could create a version with only sm_10 instead of all combinations and see if that works since the v2.03 app only used sm_10 and seems to work OK for most. In theory, all devices should be backward compatible, but without testing on one of every type of GPU...

mrspooky
Send message
Joined: 14 Aug 11
Posts: 3
Credit: 16,058,341
RAC: 0
Message 16501 - Posted: 16 May 2013, 20:24:11 UTC - in response to Message 16498.
Last modified: 16 May 2013, 20:45:14 UTC

I have some experience using app_info.xml, I was messing with it on milkyway@home and primegrid when I heard about the possibility of multiple applications running on gpu.

Could you create this version with sm_10 only flag, please?

I'd like to know if it's my gpu that has a problem, as I tested primegrid with cuda 5 and I got the same exception.
Maybe this issue is associated with driver or libcuda giving wrong values for some parameters, like this:

(only differences)

Windows client_state.xml:


<coproc_cuda>
<available_ram>4149374976.000000</available_ram>
<drvVersion>31422</drvVersion>
<maxGridSize>65535 65535 65535</maxGridSize>
<coproc_opencl>
<max_clock_frequency>758</max_clock_frequency>
<max_compute_units>7</max_compute_units>
</coproc_opencl>
</coproc_cuda>


Linux client_state.xml:

<coproc_cuda>
<available_ram>4037357568.000000</available_ram>
<drvVersion>0</drvVersion>
<maxGridSize>2147483647 65535 65535</maxGridSize>
<coproc_opencl>
<max_clock_frequency>7018911954001462006</max_clock_frequency>
<max_compute_units>7164775588903780359</max_compute_units>
</coproc_opencl>
</coproc_cuda>


But that's just my conjecturing. ;)

mrspooky
Send message
Joined: 14 Aug 11
Posts: 3
Credit: 16,058,341
RAC: 0
Message 16502 - Posted: 16 May 2013, 20:43:11 UTC - in response to Message 16498.
Last modified: 16 May 2013, 20:44:31 UTC

sorry, double post.

Alez
Send message
Joined: 28 Nov 12
Posts: 29
Credit: 1,128,215,816
RAC: 981,672
Message 17691 - Posted: 25 Oct 2013, 12:08:37 UTC

I may be having the same issue, or at least an issue on this host. http://boinc.thesonntags.com/collatz/results.php?hostid=134424

mini collatz on cpu v2.02 works
solo_collatz v4.09 (cuda50) works fine on nVidia 660ti ( 3.0 compute)

mini_collatz v4.04 (cuda50) fails immediately
collatz v4.04 (cuda50) fails immediately

Outcome Computation error
Client state Compute error
Exit status 136 (0x88) Unknown error number

any ideas ?

Werkstatt
Send message
Joined: 22 Nov 09
Posts: 14
Credit: 23,623,445
RAC: 0
Message 17738 - Posted: 4 Nov 2013, 14:33:40 UTC

Hi,

I'm new in the Linux world.
Today I've tried collatz on this machine :
http://boinc.thesonntags.com/collatz/show_host_detail.php?hostid=135224

This is what happens:

<core_client_version>7.2.7</core_client_version>
<![CDATA[
<message>
process got signal 8
</message>
<stderr_txt>
Collatz Conjecture v4.04 x86_64 for CUDA 5.0
Based on the AMD Brook+ kernels by Gipsel
verbose=1
Name GeForce GTX 550 Ti
Compute 2.1
Parameters --device 0
Start 2382441411484387617128
Checking 824633720832 numbers
Numbers/Kernel 65536
Kernels/Reduction 256
Numbers/Reduction 16777216
Reductions/WU 49152
Threads 0
Reduction CPU

</stderr_txt>

Fails with 136 (0x88) Unknown error number

The thing with the client_state.xml:
where did they get the numbers from? Will they fit on my system?

Cheers,

Alexander

Werkstatt
Send message
Joined: 22 Nov 09
Posts: 14
Credit: 23,623,445
RAC: 0
Message 17740 - Posted: 4 Nov 2013, 15:50:03 UTC

As posted somewhere, tho solo collatz work fine.
I've set the preferences according.

Profile Grimbert Jerome
Send message
Joined: 9 Feb 12
Posts: 3
Credit: 49,754,488
RAC: 1,004
Message 18247 - Posted: 8 Jan 2014, 22:21:59 UTC

I have the same issue (all v4.04 (collatz & mini) cuda50) end in error).
Graphic card is a GTX 470, OS is linux 64 bits.

I noticed that windows got a v4.07, is it related to that trouble ?

Matt
Send message
Joined: 12 Jun 13
Posts: 1
Credit: 4,678,011
RAC: 376
Message 18269 - Posted: 12 Jan 2014, 3:44:55 UTC
Last modified: 12 Jan 2014, 3:47:10 UTC

I have also been getting instant computation errors due to signal 8 with mini_collatz v4.04 (cuda50) and collatz v4.04 (cuda50) under Lubuntu 13.10 x64. solo_collatz v4.09 (cuda50) works perfectly, as well as mini_collatz v2.02


CPU: AMD Athlon 64 X2 3800+ (no overclock)
GPU: GeForce GT520 (factory overclocked)


http://boinc.thesonntags.com/collatz/result.php?resultid=155639039

<core_client_version>7.2.7</core_client_version>
<![CDATA[
<message>
process got signal 8
</message>
<stderr_txt>
Collatz Conjecture v4.04 x86_64 for CUDA 5.0
Based on the AMD Brook+ kernels by Gipsel
verbose=1
Name GeForce GT 520
Compute 2.1
Parameters --device 0
Start 2384694123205529151848
Checking 103079215104 numbers
Numbers/Kernel 65536
Kernels/Reduction 256
Numbers/Reduction 16777216
Reductions/WU 6144
Threads 0
Reduction CPU

</stderr_txt>
]]>


Post to thread

Message boards : Unix/Linux : Issue running collatz 4.04 (cuda50)


Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.