Pending credit link
log in

Advanced search

Message boards : Web site : Pending credit link

Author Message
Profile S@NL - FilmFreak
Send message
Joined: 18 Jul 09
Posts: 6
Credit: 67,360,783
RAC: 15,885
Message 18040 - Posted: 6 Dec 2013, 15:30:09 UTC

The 'Pending Credit' link on the my account page links to I don't see any credit there, while I have 14 tasks waiting at this moment. I think it would be nice to link it to or show the pending credit tasks on the page.

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Send message
Joined: 11 Jun 09
Posts: 2528
Credit: 740,580,099
RAC: 0
Message 18047 - Posted: 6 Dec 2013, 22:30:45 UTC

Yep. That is a bug in the server software that I keep fixing every time I deploy a new version. The problem is due to the creditNew which no longer expects the client to estimate the credit they should receive. So, the estimated credit is 0. The pending page expects that valid WUs would have expected credit and, because there isn't any, is incorrectly assumes that the WUs are not valid. So, in the past, I changed the code so it uses the "default" credit for each type of WU as an estimate. So, either I missed adding my fix to the last release or the release I'm running has a new and improved "feature" (a.k.a. bug).

That, or the transitioner backlog is the culprit. There are a number of issues at present and I don't know which are related and which aren't yet.

Post to thread

Message boards : Web site : Pending credit link

Main page · Your account · Message boards

Copyright © 2018 Jon Sonntag; All rights reserved.