Phasing out Multi-Size
log in

Advanced search

Message boards : News : Phasing out Multi-Size

Previous · 1 · 2
Author Message
Profile Tarmo Ilves
Avatar
Send message
Joined: 6 Jun 10
Posts: 8
Credit: 1,655,714,500
RAC: 1,664,001
Message 19174 - Posted: 25 Apr 2014, 22:19:09 UTC - in response to Message 19172.

After 3h 27min 53,6% completed.


Double check the file: large_collatz_6.04_windows_x86_64__opencl_amd_gpu.CONFIG

Suspect it may be blank because that's on the slow side for a 7990, you should be either side of 4.5hrs+ for the complete file depending on GPU clocks that you have set.

Mine (on 7970s - clocks 1185/1685) is below:

verbose=1
items_per_kernel=22
kernels_per_reduction=9
threads=8
sleep=1

Depending on how it runs on the 7990, you might need to reduce "items per kernal" to 21

It is not empty because I already configured it.
verbose=1
items_per_kernel=20
kernels_per_reduction=9
threads=8
sleep=1
build_options=-Werror

Both GPUs are set to not exceed 950MHz

Profile Zydor
Avatar
Send message
Joined: 19 Aug 09
Posts: 364
Credit: 840,811,292
RAC: 0
Message 19175 - Posted: 25 Apr 2014, 22:25:20 UTC - in response to Message 19174.
Last modified: 25 Apr 2014, 22:28:04 UTC

The 7990 will definitely take 21 with ease, some will take 22.

Definitely worth changing to at least 21 see how she runs, and if settled, try 22 after a couple of WUs - it will make a marked difference in speeding up crunching, might need to bump up the GPU fans a small amount (aka 2 or 3 %), but that's not drastic.

[AF>FAH-Addict.net]toTOW
Send message
Joined: 15 Oct 10
Posts: 15
Credit: 100,193,374
RAC: 0
Message 19180 - Posted: 25 Apr 2014, 23:49:13 UTC - in response to Message 19173.

Still no Large WUs for my R9 290X :'(


In BOINC Manager, make sure your local preferences are set to accept , say, 2 days of work... If ur local preferences queue is small, the 'system' will not send anything because it thinks there will not be enough time to run the large wu's.

Also in Collatz preferences make sure you have the 'run test units' box ticked.

Plus, in the 'run only selected application' box, expand it and make sure 'large' work units is selected.

Then restart Boinc so it reads the new preferences. After much fiddling, that is what worked for me.

I already set all this ...

I have set up my caches to get 7 days of work (which never happened with multi size Solo) and Collatz is the only GPU project enabled.

I have only Large application selected in preferences, with "accept test applications" checked and "allow wrok from othe applications if none is available for the selected ones" unchecked.

I don't know what much I can do ... I thought Large WUs would work just as Solo did ...

P.S I just upgraded my Catalyst drivers : 26/04/2014 00:58:26 | | OpenCL: AMD/ATI GPU 0: Hawaii (driver version 1445.5 (VM), device version OpenCL 1.2 AMD-APP (1445.5), 3072MB, 3072MB available, 3520 GFLOPS peak)

chf1949
Send message
Joined: 18 Mar 11
Posts: 16
Credit: 1,363,723,776
RAC: 0
Message 19181 - Posted: 26 Apr 2014, 0:47:33 UTC - in response to Message 19180.
Last modified: 26 Apr 2014, 0:48:07 UTC

I don't know what much I can do ... I thought Large WUs would work just as Solo did ...


I'm stumped.. this IS a is BETA test, so hopefully Slicker will scan the comments to see what is going on and offer a suggestion to get it going. sorry it didn't go well, and wish I could offer more help.

Profile Peciak
Avatar
Send message
Joined: 4 Aug 09
Posts: 13
Credit: 669,955,177
RAC: 627
Message 19189 - Posted: 26 Apr 2014, 5:34:27 UTC

Large Collatz Conjecture
WIN 7 64, ATI 7970 drivers 14.4
1xWU 18,955.41 sek -----> 237,221.91 pkt
is well

Profile DeleteNull
Volunteer tester
Avatar
Send message
Joined: 18 Sep 09
Posts: 29
Credit: 2,087,516,533
RAC: 0
Message 19192 - Posted: 26 Apr 2014, 10:01:05 UTC - in response to Message 19189.

Large Collatz Conjecture
WIN 7 64, ATI 7970 drivers 14.4
1xWU 18,955.41 sek -----> 237,221.91 pkt
is well


Which config did you use?

Profile Peciak
Avatar
Send message
Joined: 4 Aug 09
Posts: 13
Credit: 669,955,177
RAC: 627
Message 19193 - Posted: 26 Apr 2014, 10:33:01 UTC

large_collatz_6.04_windows_x86_64__opencl_amd_gpu.config

verbose=1
items_per_kernel=22
kernels_per_reduction=9
threads=8
sleep=1


solo_collatz_6.04_windows_x86_64__opencl_amd_gpu.config

verbose=1
items_per_kernel=22
kernels_per_reduction=9
threads=8
sleep=1


app_config.xml


<app_config>
<app>
<name>solo_collatz</name>
<max_concurrent>1</max_concurrent>
<gpu_versions>
<gpu_usage>1</gpu_usage>
<cpu_usage>2</cpu_usage>
</gpu_versions>
</app>
<app>
<name>large_collatz</name>
<max_concurrent>1</max_concurrent>
<gpu_versions>
<gpu_usage>1</gpu_usage>
<cpu_usage>2</cpu_usage>
</gpu_versions>
</app>
</app_config>

Profile DeleteNull
Volunteer tester
Avatar
Send message
Joined: 18 Sep 09
Posts: 29
Credit: 2,087,516,533
RAC: 0
Message 19196 - Posted: 26 Apr 2014, 12:30:55 UTC - in response to Message 19193.

Thank you for the info.

I am using large_collatz_6.04_windows_x86_64__opencl_amd_gpu.config and solo_collatz_6.04_windows_x86_64__opencl_amd_gpu.config without app_config.xml.
(items_per_kernel=21)

This seems to be 5% slower, so i will switch to items_per_kernel=22

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 19197 - Posted: 26 Apr 2014, 14:02:30 UTC - in response to Message 19165.

I'm asking for mini and micro for my wimpy GPUs, server sez nothing available.

edit: CUDA only

Micro won't happen. Even an 8400 GS can do a mini in a few hours. I had to adjust the shared memory on the server before I could add more apps. Now that that's done, I can start adding more apps. Looks like the concensus is that we need all apps for mini for GPUs and CPUs.

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 19198 - Posted: 26 Apr 2014, 14:06:26 UTC - in response to Message 19196.

Thank you for the info.

I am using large_collatz_6.04_windows_x86_64__opencl_amd_gpu.config and solo_collatz_6.04_windows_x86_64__opencl_amd_gpu.config without app_config.xml.
(items_per_kernel=21)

This seems to be 5% slower, so i will switch to items_per_kernel=22


Same app. It was renamed to match the app name. If you do a bit comparison, you will see that solo and large apps have no differences. So, the settings that worked with the solo app are the same settings to use with the large app. Or mini. Or micro for that matter.

[AF>FAH-Addict.net]toTOW
Send message
Joined: 15 Oct 10
Posts: 15
Credit: 100,193,374
RAC: 0
Message 19204 - Posted: 27 Apr 2014, 0:23:15 UTC

I finally got 7 Large WUs ... the first one is currently running fine ... I'll report back when I have completed a few :D

Acey Pilot
Avatar
Send message
Joined: 13 Jan 14
Posts: 7
Credit: 54,938,691
RAC: 0
Message 19208 - Posted: 27 Apr 2014, 5:18:55 UTC

Getting GPU utilization of only 63% with first large work unit. Large work unit GPU config has same settings as Solo Callatz, which is running fine at 99%. I have dual GPUs and have restarted system several times. Any Ideas?

Profile Zydor
Avatar
Send message
Joined: 19 Aug 09
Posts: 364
Credit: 840,811,292
RAC: 0
Message 19221 - Posted: 27 Apr 2014, 9:35:13 UTC - in response to Message 19208.
Last modified: 27 Apr 2014, 9:40:34 UTC

63% ..... sounds like the third configuration file is blank. Take a look at:

http://boinc.thesonntags.com/collatz/forum_thread.php?id=1009

The file you are looking for in the main Collatz directory is:

large_collatz_6.04_windows_x86_64__opencl_amd_gpu.CONFIG

You have NVidia so the file name will be slightly different (I am AMD)

Profile scott safford*
Send message
Joined: 10 Jan 11
Posts: 3
Credit: 605,207,389
RAC: 0
Message 19301 - Posted: 1 May 2014, 12:06:15 UTC

I have only solo checked but im getting all sizes of wu's any particular reason for this?

Profile Pooh Bear 27
Avatar
Send message
Joined: 1 Aug 10
Posts: 54
Credit: 108,227,920
RAC: 0
Message 19302 - Posted: 1 May 2014, 13:09:50 UTC - in response to Message 19301.

I have only solo checked but im getting all sizes of wu's any particular reason for this?

Solo had auto sized units and many are still in the system, so you may get some of them as other systems time out or abort them.

Until they are all finished, we will all get multiple sized Solo units for a while.

Rick A. Sponholz
Avatar
Send message
Joined: 20 Apr 14
Posts: 6
Credit: 483,584,897
RAC: 1,325,944
Message 19303 - Posted: 1 May 2014, 14:20:01 UTC - in response to Message 19162.
Last modified: 1 May 2014, 14:20:23 UTC

I got my first large WU for my Intel-GPU. 19 minutes for 0.2% ==> it will be running about 6,6 days with a Deadline of 7 days. I stop it, because the deadline give not enough time to safely complete this unit.


Slicker,
Has anyone completed a large wu on an intelgpu? Based on my results so far, the deadline is too tight to complete, forcing me to not accept large wu's even though the dual gtx690's on the same machines are EAGER to crunch large wu's. PLEASE either abandon creation of large wu's for intelgpu, or give us more time to crunch them. Also, PLEASE let us know what you've done about this via BOINC Notices, so we don't have to search all the forums to see if/when you've responded. Thanks in advance for your prompt attention to this issue, Rick
____________

Previous · 1 · 2
Post to thread

Message boards : News : Phasing out Multi-Size


Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.