Mini Collatz compute error
log in

Advanced search

Message boards : Number crunching : Mini Collatz compute error

Author Message
KWSN - Housekeeper of Camelot
Send message
Joined: 8 Mar 10
Posts: 3
Credit: 137,372,428
RAC: 0
Message 19461 - Posted: 13 May 2014, 10:42:27 UTC

Hi,

I noticed today that the mini collatz app is running into compute errors after 2 secs:

http://boinc.thesonntags.com/collatz/result.php?resultid=6830576

I had this once with a bad ATI driver but it looks now that the previos driver version also does this .....

Any suggestions?

Cheers

HoC
____________

KWSN - Housekeeper of Camelot
Send message
Joined: 8 Mar 10
Posts: 3
Credit: 137,372,428
RAC: 0
Message 19462 - Posted: 13 May 2014, 10:56:08 UTC
Last modified: 13 May 2014, 10:56:22 UTC

Looks like I found the prob ..... seems the config file for the ati14 app is missing (for the x86 and x64 open_cl apps there is already a config file there) ....

Cheers

HoC

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 2
Message 19465 - Posted: 13 May 2014, 14:34:09 UTC - in response to Message 19462.

Looks like I found the prob ..... seems the config file for the ati14 app is missing (for the x86 and x64 open_cl apps there is already a config file there) ....

Cheers

HoC


The ati14 app doesn't use a config file. It is based on the v2.09 app and uses command line parameters rather than a config file. On the other hand, it really doesn't need either. Unless your GPU is pre-HD 5000, it will probably run the opencl app as fast or even faster than the ati14 app.

KWSN - Housekeeper of Camelot
Send message
Joined: 8 Mar 10
Posts: 3
Credit: 137,372,428
RAC: 0
Message 19477 - Posted: 14 May 2014, 11:01:38 UTC
Last modified: 14 May 2014, 11:27:16 UTC

Hi Slicker,

well unfortunately the ati14 are still crashing .... any ideas?

See for example: http://boinc.thesonntags.com/collatz/result.php?resultid=6846136

The card is a Radeon HD6670 ..... and the OpenCL works like a charm so I'll better deactivate the ati14 wu's in the settings. -done -

Hmm, I found a

mini_collatz_6.04_windows_x86_64__ati14.exe
mini_collatz_6.04_windows_x86_64__ati14.pdb

and a

mini_collatz_6.04_windows_x86_64__opencl_amd_gpu.config

but no exe or pdb with mini_collatz_6.04_windows_x86_64__opencl_amd_gpu

maybe that is also a problem.

Looks like a reset of the project did now the trick ....

Cheers

HoC

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 2
Message 19479 - Posted: 14 May 2014, 14:33:44 UTC - in response to Message 19477.

Hi Slicker,

well unfortunately the ati14 are still crashing .... any ideas?

See for example: http://boinc.thesonntags.com/collatz/result.php?resultid=6846136

The card is a Radeon HD6670 ..... and the OpenCL works like a charm so I'll better deactivate the ati14 wu's in the settings. -done -

Hmm, I found a

mini_collatz_6.04_windows_x86_64__ati14.exe
mini_collatz_6.04_windows_x86_64__ati14.pdb

and a

mini_collatz_6.04_windows_x86_64__opencl_amd_gpu.config

but no exe or pdb with mini_collatz_6.04_windows_x86_64__opencl_amd_gpu

maybe that is also a problem.

Looks like a reset of the project did now the trick ....

Cheers

HoC


Glad you got it working.

It has always annoyed me that if there is a typo in an app_info.xml that BOINC deletes files. WTF? Why not leave it well enough alone and just log that there is an error or invalid XML? Why delete files that need to be there?


Post to thread

Message boards : Number crunching : Mini Collatz compute error


Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.