solo_collatz
log in

Advanced search

Message boards : Number crunching : solo_collatz

Author Message
Profile Highlander_6596
Avatar
Send message
Joined: 10 May 14
Posts: 9
Credit: 743,391,554
RAC: 1,226,672
Message 19463 - Posted: 13 May 2014, 11:48:08 UTC

I have three PCs each running Win7 with AMD7770 GPUs.
They are each running BOINC version 7.2.42.
I use the app_config.xml

<app_config>
<app>
<name>solo_collatz</name>
<max_concurrent>4</max_concurrent>
<gpu_versions>
<gpu_usage>0.25</gpu_usage>
<cpu_usage>0.05</cpu_usage>
</gpu_versions>
</app>
</app_config>

This configuration works fine in two PCs.

However, one PC produces an error message...
5/13/2014 4:10:33 AM | Collatz Conjecture | Your app_config.xml file refers to an unknown application 'solo_collatz'. Known applications: None


All three PCs contain the same app_config.xml file configuration.
All three PCs are assigned to the same Collatz Profile.
So, the question is...
Why does one of the PC's produce the error and refuses to download any solo collatz WUs?

This is the config of the third PC...


Thanks for the assist.
____________

Profile Zydor
Avatar
Send message
Joined: 19 Aug 09
Posts: 364
Credit: 840,811,292
RAC: 0
Message 19464 - Posted: 13 May 2014, 14:16:57 UTC - in response to Message 19463.
Last modified: 13 May 2014, 15:12:23 UTC

However, one PC produces an error message...

5/13/2014 4:10:33 AM | Collatz Conjecture | Your app_config.xml file refers to an unknown application 'solo_collatz'. Known applications: None


I've come across that one before .... and there is a simple answer that escapes me at present .... still thinking ....

But, meanwhile

CPU
Strongly suggest you increase those CPU allocations to a bare minimum of 0.25 CPU, hugely preferable to make it 0.5CPU per WU

The classic setting 0.05 (etc) beloved of many BOINC applications will not work here. The application needs a barest minimum of 0.25 CPU to get anywhere near optimum timings - but you should go for 0.5 to give it maximum room to do its thing.

I have seen users results go from 6000 secs a WU plummet down to a hugely faster time by a factor of 5, 6, 7 times or more or more depending on the application being run.

Using a setting of 0.05 (etc) CPU will throttle the application, use 0.5 and give it room to work.

GPU
You will gain significant advantage by running two Solo Collatz concurrently on a GPU (the lower end GPUs not so much), but any more than that will throttle it. As a rule-of-thumb, the max number of Solo Collatz WU per GPU should be no more than two. (Watch your GPU temperatures - with two per GPU - the work rate for the GPU goes up, and heat rises, usually increasing the fan speed by circa 2 or 3% gets that sorted)

Will they run with more on settings ..... for sure, but you gain nothing, and multiply problems over heat, complexity blah blah ... the list goes on. Stay at 0.5 CPU, and max two GPU WU concurrently on each GPU (for Solo Collatz), and that's pretty well optimum for the vast majority (circa 99%+) of folk.

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 19466 - Posted: 13 May 2014, 14:38:09 UTC

The simple answer is that you have to run at least one solo_collatz WU on a machine before putting the app_config.xml file on it. In other words, if you have the app_config.xml file, BOINC expects to find the app on the PC already and it doesn't download it if it doesn't exist. So, either rename the app_config.xml, wait for BOINC to download the files, and then change the name back to app_config.xml.

Profile Highlander_6596
Avatar
Send message
Joined: 10 May 14
Posts: 9
Credit: 743,391,554
RAC: 1,226,672
Message 19469 - Posted: 13 May 2014, 17:54:20 UTC - in response to Message 19466.

The simple answer is that you have to run at least one solo_collatz WU on a machine before putting the app_config.xml file on it. In other words, if you have the app_config.xml file, BOINC expects to find the app on the PC already and it doesn't download it if it doesn't exist. So, either rename the app_config.xml, wait for BOINC to download the files, and then change the name back to app_config.xml.

Thought of that. Tried it, but didn't work. Will try it again along with the .5 vice .05 suggestion.

Wish me luck.

Profile Highlander_6596
Avatar
Send message
Joined: 10 May 14
Posts: 9
Credit: 743,391,554
RAC: 1,226,672
Message 19470 - Posted: 13 May 2014, 18:29:12 UTC - in response to Message 19469.

The simple answer is that you have to run at least one solo_collatz WU on a machine before putting the app_config.xml file on it. In other words, if you have the app_config.xml file, BOINC expects to find the app on the PC already and it doesn't download it if it doesn't exist. So, either rename the app_config.xml, wait for BOINC to download the files, and then change the name back to app_config.xml.

Thought of that. Tried it, but didn't work. Will try it again along with the .5 vice .05 suggestion.

Wish me luck.

PC1 took to the .5 setting like a duck to water.

PC2 seems to ignore the .5 setting and continues to run at .05.
Have turned off the New Work to let the WUs finish. I'll then turn it back on and see if they get picked up at .5 or .05.

PC3 still rejects Collatz's GPU work. The app_config file has been deleted from the folder. Still not joy.

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 19471 - Posted: 13 May 2014, 19:56:24 UTC - in response to Message 19470.

The simple answer is that you have to run at least one solo_collatz WU on a machine before putting the app_config.xml file on it. In other words, if you have the app_config.xml file, BOINC expects to find the app on the PC already and it doesn't download it if it doesn't exist. So, either rename the app_config.xml, wait for BOINC to download the files, and then change the name back to app_config.xml.

Thought of that. Tried it, but didn't work. Will try it again along with the .5 vice .05 suggestion.

Wish me luck.

PC1 took to the .5 setting like a duck to water.

PC2 seems to ignore the .5 setting and continues to run at .05.
Have turned off the New Work to let the WUs finish. I'll then turn it back on and see if they get picked up at .5 or .05.

PC3 still rejects Collatz's GPU work. The app_config file has been deleted from the folder. Still not joy.


Looking at http://boinc.thesonntags.com/collatz/hosts_user.php?userid=53433 only two of them have the complete AMD driver. The third isn't showing that it supports OpenCL so it will never download work until that is fixed regardless of whether an app config exists or not.

Profile Highlander_6596
Avatar
Send message
Joined: 10 May 14
Posts: 9
Credit: 743,391,554
RAC: 1,226,672
Message 19472 - Posted: 13 May 2014, 23:52:51 UTC - in response to Message 19471.

For PC2 - With the existing 0.05 WUs completed, I opened the door and the new WUs are picked up at 0.5.

Still working on PC3. Got delayed by dinner. Sorry.


Post to thread

Message boards : Number crunching : solo_collatz


Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.