Collatz Sieve 1.08 Released for Windows
log in

Advanced search

Message boards : News : Collatz Sieve 1.08 Released for Windows

Author Message
Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 21022 - Posted: 14 Aug 2015, 23:55:30 UTC

The 1.07 added variable sieve sizes but introduced a bug in the kernel that was causing it to returning results outside the bounds of the numbers being checked which results in them being invalid. Version 1.08 should fix that problem. Please let me know if you run into any difficulties.

Anthony Ayiomamitis
Send message
Joined: 21 Jan 15
Posts: 48
Credit: 1,078,484,423
RAC: 10,081,406
Message 21024 - Posted: 15 Aug 2015, 0:20:04 UTC - in response to Message 21022.

Slicker,

Will anything be done with units erroneously tagged as invalid due to this error? It translates to over 5k in credits for me.

Anthony Ayiomamitis
Send message
Joined: 21 Jan 15
Posts: 48
Credit: 1,078,484,423
RAC: 10,081,406
Message 21025 - Posted: 15 Aug 2015, 0:39:04 UTC - in response to Message 21024.

Slicker, the new version is bombing out on errors. Here is a sample: http://boinc.thesonntags.com/collatz/result.php?resultid=20825796

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 21029 - Posted: 15 Aug 2015, 17:51:44 UTC - in response to Message 21025.

Slicker, the new version is bombing out on errors. Here is a sample: http://boinc.thesonntags.com/collatz/result.php?resultid=20825796



Aaaaaarrrrggggghhhhh! I specifically tested each of the 64-bit apps to make sure they ran OK on full WUs since they had problems with 1.07. Looks like I will need to pull them out, or at least the Intel GPU one until I get it working.

Anthony Ayiomamitis
Send message
Joined: 21 Jan 15
Posts: 48
Credit: 1,078,484,423
RAC: 10,081,406
Message 21030 - Posted: 15 Aug 2015, 19:22:44 UTC - in response to Message 21029.

It somehow corrected itself a few hrs later. Everything has been humming the past 18 hrs very smoothly.

Corsair
Avatar
Send message
Joined: 16 Nov 09
Posts: 21
Credit: 826,550,448
RAC: 3,957,314
Message 21031 - Posted: 15 Aug 2015, 19:50:04 UTC

When will be released the version windows x64??

I use not to run if possible obsolete x32 code app.
____________
over the sailor's grave doesn't grove grass.

Corsair

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 21033 - Posted: 15 Aug 2015, 21:32:08 UTC - in response to Message 21031.

When will be released the version windows x64??

I use not to run if possible obsolete x32 code app.


I try and run only 64 bit apps on my CPUs but for the GPUs, it really doesn't matter. For them, 64 bit functions are emulated. They really only do 32-bit math. But, that having been said, I released 1.09 which I hope fixes the issue. I can't duplicate it in stand-alone mode. The only place the code works differently is how it parses the WU name in standalone mode vs when run from BOINC. Technically, it shouldn't need to even read the input file since the WU name gives it the two pieces of information it needs: the starting number and the count of numbers that will be checked. Rather than dink with it any more, I just commented out the so-called smart code and read the start and stop numbers from the actual WU just like it does when in stand-alone mode. I really hope that's the only change needed.

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 21034 - Posted: 15 Aug 2015, 21:41:42 UTC - in response to Message 21030.

It somehow corrected itself a few hrs later. Everything has been humming the past 18 hrs very smoothly.


LOL. That's because BOINC decided to run 32-bit apps on your 64-bit machine. For GPU apps, it really makes no difference. For CPU apps, it __should__ learn that the 64-bit apps run in half the time as their 32-bit counterparts. Unfortunately, getting BOINC to learn is about like teaching a cat to roll over and play dead. Short of shooting it, it just isn't going to happen. ;-)

The no_alt_platform flag in the cc_config.xml file will cause it to ONLY run 64-bit apps that that is a global setting. If a project doesn't have 64-bit apps, it won't get any work if that is set.

Corsair
Avatar
Send message
Joined: 16 Nov 09
Posts: 21
Credit: 826,550,448
RAC: 3,957,314
Message 21041 - Posted: 16 Aug 2015, 14:46:37 UTC - in response to Message 21022.
Last modified: 16 Aug 2015, 14:57:00 UTC

opencl_intel_gpu: 1.09 x64 works in my i7 it doesn't in my surface i5 but 1.08 x32 works

opencl_nvidia_gpu: (correction) 1.09 x64 working correctly.

opencl_amd_gpu: same computer APU AMD with R7 1.09 x32 works but in HD7770 doesn't now computer is crunching 1.08 x32 with no problem in R7 still not tested the HD7770 because is with Bitcoin Utopia project.
(update: already tested HD7770 running with 1.08 x32 correctly).

all computer with windows 10 pro x64 and BOINC 7.6.6 x64 too.
____________
over the sailor's grave doesn't grove grass.

Corsair

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 21042 - Posted: 16 Aug 2015, 15:07:21 UTC - in response to Message 21041.

opencl_intel_gpu: 1.09 x64 works in my i7 it doesn't in my surface i5 but 1.08 x32 works


If it works on one and not the other, I have to wonder whether it is a driver issue. If it was a bug in the app, I would expect it to not work on any machines or to at least run for a while before failing. What driver version is the i7 using? What version is the i5 using?

opencl_nvidia_gpu: (correction) 1.09 x64 working correctly.

Yeah!

opencl_amd_gpu: same computer APU AMD with R7 1.09 x32 works but in HD7770 doesn't now computer is crunching 1.08 x32 with no problem in R7 still not tested the HD7770 because is with Bitcoin Utopia project.
(update: already tested HD7770 running with 1.08 x32 correctly).

all computer with windows 10 pro x64 and BOINC 7.6.6 x64 too.


So Win 10 pro works or doesn't work?

If you compare the executables, you will find that the nVidia, AMD, and Intel are the exact same application because OpenCL is supposed to be universal. If it works on one, it should work an all the others. They have been copied and renamed only to make it easier to add the app versions to BOINC.

Crystal Pellet
Send message
Joined: 12 Jul 09
Posts: 9
Credit: 16,450,326
RAC: 0
Message 21044 - Posted: 16 Aug 2015, 16:14:34 UTC
Last modified: 16 Aug 2015, 17:07:07 UTC

Versions 1.04 up to 1.08 were working on my ATI 7770 where 1.04 was the very best version.

Since 1.09 only errors after a few seconds runtime:

The last 2 tasks:

http://boinc.thesonntags.com/collatz/result.php?resultid=20886027
http://boinc.thesonntags.com/collatz/result.php?resultid=20886120

Edit: Got the 32bit version 1.08 and now it's working again!

Corsair
Avatar
Send message
Joined: 16 Nov 09
Posts: 21
Credit: 826,550,448
RAC: 3,957,314
Message 21046 - Posted: 16 Aug 2015, 19:21:33 UTC - in response to Message 21042.
Last modified: 16 Aug 2015, 19:26:13 UTC

Win 10 pro x64 is in all my computers and works collatz Sieve and in another not so much the latest apps.

i7 HD Graphics 4600 driver Intel 10.18.15.4256 10/07/2015
i5 HD Graphics 4000 driver Intel 10.18.10.4252 10/07/2015

as told before 1.09 x64 works in i7
1.09 x64 gives error after being 11 sec running in i5 but now working correctly with 1.08 x32 because app revert itself to 1.08.

in the computer with AMD APU/GPU
it was running well 1.09 x32 with GPU AMD R7 but when the HD7770 ended the warehouse of Bitcoin started with 1.09 x32 and all WU in stock gave error after around 6 seconds running the stock was emptied after some seconds and looks like the the project revert itself to 1.08 x32 (amd_gpu) and now both running well.

in one of the error result of the 1.09 amd_gpu I have seen that it's done mention to nvidia.

Linked PDB Filename : D:\Source\CollatzSieveV1\x64\Release\collatz_sieve_1.09_windows_x86_64__opencl_nvidia_gpu.pdb


http://boinc.thesonntags.com/collatz/result.php?resultid=20856092
____________
over the sailor's grave doesn't grove grass.

Corsair

Corsair
Avatar
Send message
Joined: 16 Nov 09
Posts: 21
Credit: 826,550,448
RAC: 3,957,314
Message 21054 - Posted: 17 Aug 2015, 15:56:23 UTC

restarted jobs in Surface with i5 Intel HD4000 and downloaded work for intel_gpu 1.09 x64 all wu finished with error only running one second.

e.g. http://boinc.thesonntags.com/collatz/result.php?resultid=20927188

already downloaded automatically 1.09 x64 for the AMD APU/GPU but not yet finished the 1.08 WU.

updated: all giving error either R7 either HD7770 after less than one second running.

e.g. http://boinc.thesonntags.com/collatz/result.php?resultid=20923474 ;-(
____________
over the sailor's grave doesn't grove grass.

Corsair

Corsair
Avatar
Send message
Joined: 16 Nov 09
Posts: 21
Credit: 826,550,448
RAC: 3,957,314
Message 21074 - Posted: 18 Aug 2015, 15:53:05 UTC - in response to Message 21054.

Same today AMD Computer downloaded 1.09 x64 all invalid after 1 second running in both of the GPU the APU R7 & HD7770 too,

e.g. http://boinc.thesonntags.com/collatz/result.php?resultid=20966513

Nvidia 1.09 x64 working fine
Intel 1.09 x64 in i7 working fine.
____________
over the sailor's grave doesn't grove grass.

Corsair

Anthony Ayiomamitis
Send message
Joined: 21 Jan 15
Posts: 48
Credit: 1,078,484,423
RAC: 10,081,406
Message 21075 - Posted: 18 Aug 2015, 19:33:27 UTC - in response to Message 21022.

The 1.07 added variable sieve sizes but introduced a bug in the kernel that was causing it to returning results outside the bounds of the numbers being checked which results in them being invalid. Version 1.08 should fix that problem. Please let me know if you run into any difficulties.


Slicker, after having run successfully a few hundred work units without the slightest problem, I just had a work unit fail to validate for the same reason cited above when I had six invalidations for no reason.

The best solution is below the lower boundary and which caused this hick-up: http://boinc.thesonntags.com/collatz/result.php?resultid=20836040

Anthony Ayiomamitis
Send message
Joined: 21 Jan 15
Posts: 48
Credit: 1,078,484,423
RAC: 10,081,406
Message 21076 - Posted: 18 Aug 2015, 22:28:11 UTC - in response to Message 21075.

Just had a large download batch under V1.09 and where each unit failed miserably within the first second of execution.

Glad to see we are back to V1.08.

For whatever its worth, here is a sample failed unit: http://boinc.thesonntags.com/collatz/result.php?resultid=20983694

Stick
Send message
Joined: 30 Apr 10
Posts: 20
Credit: 10,932,336
RAC: 48,374
Message 21078 - Posted: 19 Aug 2015, 1:10:51 UTC - in response to Message 21076.

Just had a large download batch under V1.09 and where each unit failed miserably within the first second of execution.

Glad to see we are back to V1.08.

For whatever its worth, here is a sample failed unit: http://boinc.thesonntags.com/collatz/result.php?resultid=20983694


Me, too. All of mine failed with: -1073741795 (0xffffffffc000001d) Unknown error number.


Post to thread

Message boards : News : Collatz Sieve 1.08 Released for Windows


Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.