Collatz does not use all available GPUs
log in

Advanced search

Message boards : Unix/Linux : Collatz does not use all available GPUs

Previous · 1 · 2 · 3
Author Message
vdvogt
Send message
Joined: 10 Jan 16
Posts: 38
Credit: 1,090,698,551
RAC: 0
Message 22681 - Posted: 6 Jul 2016, 12:37:18 UTC - in response to Message 22678.

Hi mmonnin,
this is my current app_config.xml

/var/lib/boinc-client/projects/boinc.thesonntags.com_collatz/app_config.xml

<app_config>

<app>
<name>collatz_sieve</name>
<max_concurrent>9</max_concurrent> ---> 8 CPUs and 1 GPU. I had tried 10 for 8 CPUs and 2 GPUs but then Boinc manager reported that both GPUS ara calculating, but the Nvidia X-Server Settings showed that only GPU0 was calculating (GPU utilisation 98%) and GPU1 was idle (GPU utilisation 0%) Somthinf must be wrong, either with Collatz or with Boinc!

<gpu_versions>
<gpu_usage>1.0</gpu_usage> --->here I tried 2.0 but with no success
<cpu_usage>1.0</cpu_usage>
</gpu_versions>

</app>

</app_config>


and this the cc_config.xml

/etc/boinc-client/cc_config.xml


<!--
This is a minimal configuration file cc_config.xml of the BOINC core client.
For a complete list of all available options and logging flags and their
meaning see: https://boinc.berkeley.edu/wiki/client_ ... figuration
-->

<cc_config>

<log_flags>
<task>1</task>
<file_xfer>1</file_xfer>
<sched_ops>1</sched_ops>
<coproc_debug>1</coproc_debug>
</log_flags>

<options>
<use_all_gpus>1</use_all_gpus>
</options>

</cc_config>


In the last days I had made some tests with several settings of cc_config.xml and app_config.xml.

In any case only ONE GPU was calculating!

AND now (with the setting above) one GPU and all CPUs are calculating BUT all 8 CPUS are calculating concurrently for ONE task!
I had seen that the calculation time for a single task is now half the time of that when a CPU is calculating one task at the time.
This means that this calculation mode is very ineffective!

How can I get back to the previous setting where every CPU was calculating one task at the time?

Is it right that commends in a xml file are beginning with a <!-- and end with -->? I would like to document my changes.


regards
Veit

vdvogt
Send message
Joined: 10 Jan 16
Posts: 38
Credit: 1,090,698,551
RAC: 0
Message 22723 - Posted: 17 Jul 2016, 14:40:55 UTC - in response to Message 22681.

Hi,
for testing I had switched to windows 10 now.
But I'm absolutely not familiar with windows, so I need some guidence.

I had written a cc_config.xml with th line
<use_all_gpus>1</use_all_gpus>
but Boinc does not find the file.
Probably it is in the wrong folder.

Where have I to place it?
Which rights has the file to have?

Also I would like to write an app_config.xml.

What should be in it for windows 10 and where shall it be?

Many thanks in anticipatiopn!

regards
Veit

Profile mikey
Avatar
Send message
Joined: 11 Aug 09
Posts: 3246
Credit: 1,700,898,456
RAC: 4,847,582
Message 22728 - Posted: 18 Jul 2016, 11:05:13 UTC - in response to Message 22723.
Last modified: 18 Jul 2016, 11:05:42 UTC

Hi,
for testing I had switched to windows 10 now.
But I'm absolutely not familiar with windows, so I need some guidence.

I had written a cc_config.xml with th line
<use_all_gpus>1</use_all_gpus>
but Boinc does not find the file.
Probably it is in the wrong folder.

Where have I to place it?
Which rights has the file to have?


It goes in the c:\program data\Boinc directory

By default the Admin has ALL rights to every file and folder they create in Windows, so new rights needed.

Also I would like to write an app_config.xml.

What should be in it for windows 10 and where shall it be?


This one goes in one more directory down from the last one
c:\program data\Boinc\Collatz

This way the file ONLY affects the project Collatz when you use it

Many thanks in anticipatiopn!

regards
Veit

vdvogt
Send message
Joined: 10 Jan 16
Posts: 38
Credit: 1,090,698,551
RAC: 0
Message 22733 - Posted: 19 Jul 2016, 17:43:11 UTC - in response to Message 22728.

Hi all,
the cc_config.xml is at it's right place in win 10 with the important line <use_all_gpus>.
But nothing had changed! Still after some restarts.
With Collatz ONLY ONE GPU is calculating!

Now, after several tests with Linux and win 10, with GPUGRID, Einstein@home and Collatz, I can definitely say that the failure is NOT at BOINC, NOT at LINUX, NOT at win 10!
With GPUGRID and Einstein@home both GPUS are calculating!

THE ONE AND ONLY THAT KEEPS IS COLLATZ!
with collatz still only ONE GPU is calculating!

Please fix that failure!

regards
Veit

StyM
Send message
Joined: 10 May 16
Posts: 5
Credit: 2,161,813,703
RAC: 0
Message 23027 - Posted: 28 Sep 2016, 18:19:36 UTC

i'm having this issue too,
have a dual 1080, previously it was computing on two cards
then now only 1 card is used, no matter what i do.

<warning>NVIDIA library reports 2 GPUs</warning>

Previous · 1 · 2 · 3
Post to thread

Message boards : Unix/Linux : Collatz does not use all available GPUs


Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.