CUDA 3.1 Application Available for Windows
log in

Advanced search

Message boards : News : CUDA 3.1 Application Available for Windows

1 · 2 · Next
Author Message
Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 9372 - Posted: 27 Aug 2010, 6:43:50 UTC

Collatz version 2.05 is now available on the Optimized Applications page for those running Windows with CUDA 3.1 drivers. It is not compatible with previous CUDA versions, so if you do not have the 257.21 (or higher) nVidia drivers installed, this is not for you. The application will run on both x86 and x64 systems.

Profile Mutiny32*
Send message
Joined: 18 Aug 10
Posts: 9
Credit: 11,815,033
RAC: 0
Message 9382 - Posted: 27 Aug 2010, 19:59:35 UTC - in response to Message 9372.

Err, gotta bit of a question. Two actually. Is the executable 64-bit? It appears to be 32 by the name of it. Second, you have the following in the app_info.xml


<cmdline>L13 I8 S0</cmdline>
<avg_ncpus>0.013</avg_ncpus>
<max_ncpus>1</max_ncpus>


That cmdline L13 is NOT GUI friendly in terms of responsiveness or even usability.

The avg_ncpus and max_ncpus different from that of the 3.1 CUDA app for my linux machine, which has 0.03 for both values. It appears to be different than the cuda23 windows app as well, because it always used a max of 0.03 CPU. This in its stock form shows up as 0.01 CPU usage. Did you mean for it to be 0.13 perhaps? Or did you find something else out that caused this change?

Transalp
Avatar
Send message
Joined: 20 Jul 10
Posts: 12
Credit: 31,830,334
RAC: 0
Message 9389 - Posted: 28 Aug 2010, 9:37:51 UTC

Hi there,

is it normal that after installation of 2.05 BOINC still reports "collatz 2.04 (cuda)" although the Task Manager reads "collatz_2.05_windows_intelx86_cuda31.exe"?

Thanks for your help
and greetings from Germany

Tom

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 9403 - Posted: 29 Aug 2010, 21:34:02 UTC - in response to Message 9389.

Hi there,

is it normal that after installation of 2.05 BOINC still reports "collatz 2.04 (cuda)" although the Task Manager reads "collatz_2.05_windows_intelx86_cuda31.exe"?

Thanks for your help
and greetings from Germany

Tom


Any 2.04 apps will show 2.04 even though it is running 2.05. Once the previously downloaded WUs are completed, it will show 2.05. That's the reason why the app_info.xml contains sections for previous versions. It keeps BOINC from aborting the previously downloaded WUs because it doesn't think it has the right app. When it downloads new work, it uses the highest version number and that's why new WUs will show up as 2.05.

jjwhalen
Avatar
Send message
Joined: 17 Apr 10
Posts: 20
Credit: 202,526,055
RAC: 0
Message 9429 - Posted: 31 Aug 2010, 3:57:53 UTC - in response to Message 9403.


Any 2.04 apps will show 2.04 even though it is running 2.05. Once the previously downloaded WUs are completed, it will show 2.05. That's the reason why the app_info.xml contains sections for previous versions. It keeps BOINC from aborting the previously downloaded WUs because it doesn't think it has the right app. When it downloads new work, it uses the highest version number and that's why new WUs will show up as 2.05.


I'm slightly confused. I traded up from v2.03 on my ComputerID 23085, a Win7_x64/Fermi GTX 465SC, (overclocked ~15% -- GPUGRID won't tolerate much higher). v2.05 installed OK, according to the readme. The confusion factor: the app_info.xml I got doesn't contain any section for the older version. v2.03 and its WUs were summarily dumped when I restarted the client. This must look to the server like the project was Reset (not WUs Aborted), because the WUs were immediately resent under the "lost children" rules.

v2.05 appears to be running fine (thanks, developer ;D ). Using the default options in the app_info.xml as provided, it appears to run 15-18% faster on my Fermi than v2.03_x64 did.

I notice that reported results are showing up in the server database as "Anonymous platform," not cuda 31. Normal, or glitch?

Minor oops in the readme: its internal title is
Collatz 2.04 CUDA Optimized Application Readme
(Yes, I definitely got the 2.05 .exe) ;)
____________
Best wishes:)

bal3wolf
Send message
Joined: 31 Dec 09
Posts: 2
Credit: 70,555,540
RAC: 0
Message 9450 - Posted: 31 Aug 2010, 18:09:18 UTC - in response to Message 9429.

Just wondering if you could point me in the right direction to modify the appinfo so i can still get work for my hd 5870.

zpm
Send message
Joined: 6 Sep 09
Posts: 9
Credit: 8,227,212
RAC: 0
Message 9451 - Posted: 31 Aug 2010, 18:30:03 UTC - in response to Message 9450.

http://boinc.thesonntags.com/collatz/power_apps.php
____________

bal3wolf
Send message
Joined: 31 Dec 09
Posts: 2
Credit: 70,555,540
RAC: 0
Message 9452 - Posted: 31 Aug 2010, 19:05:21 UTC - in response to Message 9451.

http://boinc.thesonntags.com/collatz/power_apps.php


You have to edit the appinfo to use 2 differt apps.

jjwhalen
Avatar
Send message
Joined: 17 Apr 10
Posts: 20
Credit: 202,526,055
RAC: 0
Message 9458 - Posted: 31 Aug 2010, 23:11:07 UTC

Forgot to ask:

If you install the power app and later reset the project, will you then have to go back and manually reinstall again?
____________
Best wishes:)

uBronan
Avatar
Send message
Joined: 30 Aug 09
Posts: 110
Credit: 29,134,968
RAC: 0
Message 9459 - Posted: 1 Sep 2010, 8:00:19 UTC
Last modified: 1 Sep 2010, 8:02:04 UTC

I never had to reinstall the power app, but you never know if in future boinc will change
So far i know the needed programs stays in the map unchanged when you do a project reset.
But if you disconnect from the project it becomes another matter.

Profile Dr. James S Ralph
Send message
Joined: 25 Aug 10
Posts: 2
Credit: 4,178,216
RAC: 0
Message 9486 - Posted: 3 Sep 2010, 0:43:21 UTC

What do you think of the possability of the higgs twin partice
and it implecations for temporal effects for the nature of matter in general and
the implications for t.a.r.d.i.s. Dr.James s. Ralph
____________

Profile Dr. James S Ralph
Send message
Joined: 25 Aug 10
Posts: 2
Credit: 4,178,216
RAC: 0
Message 9487 - Posted: 3 Sep 2010, 0:43:26 UTC

What do you think of the possability of the higgs twin partice
and it implecations for temporal effects for the nature of matter in general and
the implications for t.a.r.d.i.s. Dr.James s. Ralph

Kilzon
Send message
Joined: 31 Aug 10
Posts: 3
Credit: 6,934,564
RAC: 0
Message 9542 - Posted: 5 Sep 2010, 18:13:09 UTC - in response to Message 9403.

Hi there,

is it normal that after installation of 2.05 BOINC still reports "collatz 2.04 (cuda)" although the Task Manager reads "collatz_2.05_windows_intelx86_cuda31.exe"?

Thanks for your help
and greetings from Germany

Tom


Any 2.04 apps will show 2.04 even though it is running 2.05. Once the previously downloaded WUs are completed, it will show 2.05. That's the reason why the app_info.xml contains sections for previous versions. It keeps BOINC from aborting the previously downloaded WUs because it doesn't think it has the right app. When it downloads new work, it uses the highest version number and that's why new WUs will show up as 2.05.


This isn't the case, every time I install an Opp App on Collatz it immediately dumps all W/Us from any other apps. 2.05 gave me this in Boinc Messages:
[error] State file error: missing application file collatz_2.03_windows_x86_64__cuda23.exe"
[error] No application found for task: windows_x86_64 203 cuda23; discarding
[error] No application found for task: windows_x86_64 200 sse; discarding

There has to be a way to set up the xml file not to dump all of the W/Us from all other versions?????

Profile Beyond
Avatar
Send message
Joined: 30 Jul 09
Posts: 213
Credit: 939,653,252
RAC: 3,969
Message 9546 - Posted: 5 Sep 2010, 21:23:47 UTC - in response to Message 9542.

I've installed v2.05 on 4 machines and no WUs were dumped. Even the WUs in progress picked up where they were and kept right on crunching.

Kilzon
Send message
Joined: 31 Aug 10
Posts: 3
Credit: 6,934,564
RAC: 0
Message 9549 - Posted: 6 Sep 2010, 2:00:40 UTC

IDK. The XML file that is in the download that I get doesn't reference any of the old apps. It has the sections in it for the old versions but the file references all have the new file name in it. 2.05 runs great on my machine but all other W/Us get dumped.

Kilzon
Send message
Joined: 31 Aug 10
Posts: 3
Credit: 6,934,564
RAC: 0
Message 9556 - Posted: 6 Sep 2010, 17:50:52 UTC - in response to Message 9549.

Another thing I noticed is that since I installed 2.05, Collatz hasn't updated on it own. I woke up this morning and had about 11 hours worth of results sitting there waiting to be sent in. Collatz hasn't automatically updated once since I changed to 2.05. Very confusing but I'm just going back to the stock apps since everything worked swimmingly before this.

Profile [AF>EDLS] Polynesia
Avatar
Send message
Joined: 2 Sep 09
Posts: 13
Credit: 13,018,423
RAC: 0
Message 9703 - Posted: 16 Sep 2010, 18:01:17 UTC - in response to Message 9382.
Last modified: 16 Sep 2010, 18:03:22 UTC

Err, gotta bit of a question. Two actually. Is the executable 64-bit? It appears to be 32 by the name of it. Second, you have the following in the app_info.xml


<cmdline>L13 I8 S0</cmdline>
<avg_ncpus>0.013</avg_ncpus>
<max_ncpus>1</max_ncpus>




Are the lines above are set for my configuration can they be modified to adapt to it? thank you

i7 860 2.8, 8 giga ram ddr3, gtx 470, win 7 64b
____________

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 1
Message 9740 - Posted: 21 Sep 2010, 22:24:42 UTC - in response to Message 9703.

Err, gotta bit of a question. Two actually. Is the executable 64-bit? It appears to be 32 by the name of it. Second, you have the following in the app_info.xml


<cmdline>L13 I8 S0</cmdline>
<avg_ncpus>0.013</avg_ncpus>
<max_ncpus>1</max_ncpus>




Are the lines above are set for my configuration can they be modified to adapt to it? thank you

i7 860 2.8, 8 giga ram ddr3, gtx 470, win 7 64b


They will work on all configurations. The question is whether they will work best on your configuration. That depends upon whether you plan to use the computer while it is crunching or not. Those are the optimal settings for newer cards. That being said, some older cards, such as my 8400 GS, actually do better by using slightly smaller values for I and L.

PHr
Send message
Joined: 29 Mar 11
Posts: 3
Credit: 2,755,180
RAC: 0
Message 12379 - Posted: 25 May 2011, 16:00:15 UTC

Hi,

My problem:
- 20 day ago from install new NVIDIA driver 270.61 - ALL wu Collatz Conjecture (cuda31) - "Bad computing"
- ALL wu Collatz Conjecture with (cuda31) crash and still videodriver
- only Collatz Conjecture project wu(cuda31) is fail , next projects with wu(cuda31) is OK (DNETC@home...)

my hardware - notebook ASUS G51Jx with NV GTS 360M 1GB , Win7 x64

sorry, my english no good

mcz

Profile Zydor
Avatar
Send message
Joined: 19 Aug 09
Posts: 364
Credit: 840,811,292
RAC: 0
Message 12380 - Posted: 27 May 2011, 2:49:29 UTC - in response to Message 12379.

Try changing the driver - NVidia 270 driver is a bad one that caused problems in many many places.

It looks like NVidia fixed the problems and the latest driver, 275 works well.

Regards
Zy

1 · 2 · Next
Post to thread

Message boards : News : CUDA 3.1 Application Available for Windows


Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.