I want to process only GPU data and no CPU data files.
log in

Advanced search

Message boards : Number crunching : I want to process only GPU data and no CPU data files.

Author Message
Lewis F Schwaiger
Send message
Joined: 9 Sep 10
Posts: 1
Credit: 48,078
RAC: 0
Message 9674 - Posted: 14 Sep 2010, 14:39:06 UTC

I am looking for a way to avoid getting CPU data files. I do not want to interfere with the procesing of the SETI files on the CPUs. Can you help me?
____________

Claggy
Send message
Joined: 27 Sep 09
Posts: 288
Credit: 14,320,498
RAC: 0
Message 9675 - Posted: 14 Sep 2010, 15:19:30 UTC - in response to Message 9674.
Last modified: 14 Sep 2010, 15:20:18 UTC

Deselect 'Use CPU' in your Collatz Preferences.

Claggy

PeteS
Send message
Joined: 17 Jul 09
Posts: 20
Credit: 54,228,605
RAC: 0
Message 9709 - Posted: 18 Sep 2010, 8:29:51 UTC - in response to Message 9675.
Last modified: 18 Sep 2010, 8:32:44 UTC

I have deselected use CPU "since the project started" and now suddenly I am getting SSE CPU tasks on one of my hosts. Due to this I can't use Collatz, anyone else having the same "bug" ?

This host: http://boinc.thesonntags.com/collatz/show_host_detail.php?hostid=2601

Collatz is set as backup project to Milky and DNETC with 0% resource share

Claggy
Send message
Joined: 27 Sep 09
Posts: 288
Credit: 14,320,498
RAC: 0
Message 9710 - Posted: 18 Sep 2010, 9:25:07 UTC - in response to Message 9709.

Have you got your computers set to different venues, with different preferences for each?, or do you have Just the Default preferences?

You can also try the Power app for your GPU, since the app_info doesn't have the CPU app in it, you won't get any more CPU work,

Claggy

Profile mikey
Avatar
Send message
Joined: 11 Aug 09
Posts: 3241
Credit: 1,684,141,994
RAC: 6,605,672
Message 9721 - Posted: 21 Sep 2010, 14:09:01 UTC - in response to Message 9709.

I have deselected use CPU "since the project started" and now suddenly I am getting SSE CPU tasks on one of my hosts. Due to this I can't use Collatz, anyone else having the same "bug" ?

This host: http://boinc.thesonntags.com/collatz/show_host_detail.php?hostid=2601

Collatz is set as backup project to Milky and DNETC with 0% resource share


This setting was changed during a Server upgrade a while back I think but only for some people, most of us went in and reset the settings to the way we wanted them to be, have you checked yours and is it still set the way you want it to be? This did NOT affect everyone just some of us.

Profile rebel9
Send message
Joined: 15 Jul 09
Posts: 3
Credit: 3,653,728
RAC: 3,164
Message 10005 - Posted: 18 Oct 2010, 13:17:32 UTC

This is still happening. Can you look into it please? I have separate prefs set via BAM and no cpu WUs set for my work box but I still get them there.

Thanks.

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 2
Message 10006 - Posted: 18 Oct 2010, 18:05:51 UTC

When not using BAM it seems to work fine, so maybe the problem is BAM...

BAM doesn't set Collatz project preferences. Those are set on this web site. (e.g. click the "Collatz Conjecture preferences" link on the "My Account" page and unckeck "Use CPU (enforced by 6.10+ clients)" box.

Profile rebel9
Send message
Joined: 15 Jul 09
Posts: 3
Credit: 3,653,728
RAC: 3,164
Message 10009 - Posted: 19 Oct 2010, 0:04:28 UTC - in response to Message 10006.

Yes, I know and have done that. BAM is where I set up the separate profiles for my machines. Here is where I configured those profiles. Back to my original request. :-)

Thanks.

wandering willie
Send message
Joined: 18 Aug 10
Posts: 9
Credit: 18,304,587
RAC: 0
Message 10011 - Posted: 19 Oct 2010, 8:53:02 UTC

Host running ati13ati

Resource share
If you participate in multiple BOINC projects, this is the proportion of your resources used by Collatz Conjecture 100

Use CPU
(enforced by 6.10+ clients) no

Use NVIDIA GPU if present
(enforced by 6.10+ clients) no

Use ATI GPU if present
(enforced by 6.10+ clients) yes


Default computer location ---
Maximum CPU % for graphics
0 ... 100 20

Edit Collatz Conjecture preferences

Host running 2.04 cuda.

Resource share
If you participate in multiple BOINC projects, this is the proportion of your resources used by Collatz Conjecture 100
Use CPU
(enforced by 6.10+ clients) no

Use NVIDIA GPU if present
(enforced by 6.10+ clients) YES

Use ATI GPU if present
(enforced by 6.10+ clients) NO

on its web site? yes

Default computer location ---
Maximum CPU % for graphics
0 ... 100 20

Edit Collatz Conjecture preferences

My hosts are set as above both running op apps but I only get GPU WU's.

Local Host Activity set to Use GPU always.

Michael.

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 2
Message 10016 - Posted: 19 Oct 2010, 13:38:55 UTC

Enable sched_op_debug in the cc_config and then look at the log when it requests work. Does it request more than 0 seconds of CPU work even though you have disabled it in your preferences? If so, the issue is with the BOINC client and/or BAM. Please note that the client will alternate between GPU and CPU requests so you have to look through several requests to see what it is doing for sure.

Profile Fred J. Verster
Avatar
Send message
Joined: 23 Dec 09
Posts: 42
Credit: 45,162,514
RAC: 0
Message 10018 - Posted: 19 Oct 2010, 20:03:31 UTC - in response to Message 10016.

Enable sched_op_debug in the cc_config and then look at the log when it requests work. Does it request more than 0 seconds of CPU work even though you have disabled it in your preferences? If so, the issue is with the BOINC client and/or BAM. Please note that the client will alternate between GPU and CPU requests so you have to look through several requests to see what it is doing for sure.



This is why , I wanted to run COLLATZ Conjecture on GPU not CPU!

120 times faster, a EAH5870 v.s. Core i5 2.7GHz

Additional software to 'control' BOINC, only takes extra CPU cycles :)



____________

Profile Fred J. Verster
Avatar
Send message
Joined: 23 Dec 09
Posts: 42
Credit: 45,162,514
RAC: 0
Message 10022 - Posted: 20 Oct 2010, 16:38:16 UTC - in response to Message 10018.

And in your Account Settings settings for Collatz C., you've set
Default computer location ---
Maximum CPU % for graphics
0 ... 100 20
, since you don't wanna use your CPU, I wonder if it's possible to 'run' graphics, since you use GPU for crunching, depending on the load of the GPU, it's most of the times not a good idea.
And it does slow down your GPU!
A GPU, always has to 'load' input and send ouput, to CPU. Checkpoints can be used, many projects do so. (BOINC, itself can't whitout a CPU ;^))




____________

wandering willie
Send message
Joined: 18 Aug 10
Posts: 9
Credit: 18,304,587
RAC: 0
Message 10023 - Posted: 20 Oct 2010, 17:39:23 UTC

Use CPU
(enforced by 6.10+ clients) no


Default computer location ---

Maximum CPU % for graphics

0 ... 100 20

I am happy the way my setting of no CPU are working out.

Most WU's ati13ati are being returned in 30 to 40 minutes.

Against my laptop CPU haveing the folling Run time 230,169.04, CPU time 219,844.60


Michael

Profile Slicker
Volunteer moderator
Project administrator
Project developer
Project tester
Project scientist
Avatar
Send message
Joined: 11 Jun 09
Posts: 2525
Credit: 740,580,099
RAC: 2
Message 10030 - Posted: 21 Oct 2010, 14:47:46 UTC - in response to Message 10018.

Enable sched_op_debug in the cc_config and then look at the log when it requests work. Does it request more than 0 seconds of CPU work even though you have disabled it in your preferences? If so, the issue is with the BOINC client and/or BAM. Please note that the client will alternate between GPU and CPU requests so you have to look through several requests to see what it is doing for sure.



This is why , I wanted to run COLLATZ Conjecture on GPU not CPU!

120 times faster, a EAH5870 v.s. Core i5 2.7GHz

Additional software to 'control' BOINC, only takes extra CPU cycles :)


I take that to mean you have already enabled sched_op_debug and have seen that the BOINC client is requesting CPU work even though the preferences are set to not use the CPU. If that's the case, there isn't anything I can do on this end. The bug is in the BOINC client. The preferences control the client asking for work and not the server sending work. In other words, if the client asks for CPU work, the server will send it.

Claggy
Send message
Joined: 27 Sep 09
Posts: 288
Credit: 14,320,498
RAC: 0
Message 10032 - Posted: 21 Oct 2010, 18:25:36 UTC - in response to Message 10030.

Enable sched_op_debug in the cc_config and then look at the log when it requests work. Does it request more than 0 seconds of CPU work even though you have disabled it in your preferences? If so, the issue is with the BOINC client and/or BAM. Please note that the client will alternate between GPU and CPU requests so you have to look through several requests to see what it is doing for sure.



This is why , I wanted to run COLLATZ Conjecture on GPU not CPU!

120 times faster, a EAH5870 v.s. Core i5 2.7GHz

Additional software to 'control' BOINC, only takes extra CPU cycles :)


I take that to mean you have already enabled sched_op_debug and have seen that the BOINC client is requesting CPU work even though the preferences are set to not use the CPU. If that's the case, there isn't anything I can do on this end. The bug is in the BOINC client. The preferences control the client asking for work and not the server sending work. In other words, if the client asks for CPU work, the server will send it.


I know that this option does work, have had CPU use deselelected on each venue, and the computers on those venues don't get CPU work,
If you look at the Properties Page for Collatz in Boinc Manager, it should say 'Don't fetch CPU tasks',
and if you enable <work_fetch_debug> logging you should see work fetch for CPU's is blocked:

21/10/2010 19:13:16 | Collatz Conjecture | [work_fetch] CPU: fetch share 0.00 LTD 0.00 backoff dt 0.00 int 0.00 (blocked by prefs)

Boinc 6.10.18 and earlier did have a Bug with Multi Venue Preferences, where preferences from the default venue interfered with Work/School/Home venues,
I reported this issue prior to 6.10.17 becoming recommended, It was finally fixed in Boinc 6.10.19, and every version i've tested since then has worked correctly,

Claggy

Profile rebel9
Send message
Joined: 15 Jul 09
Posts: 3
Credit: 3,653,728
RAC: 3,164
Message 10033 - Posted: 21 Oct 2010, 19:43:19 UTC - in response to Message 10032.


Hi again,

I found the problem. For some reason the assignment of machines to profiles wasn't pushed from BAM. Now I've set it manually, all is well.

Thanks.


Post to thread

Message boards : Number crunching : I want to process only GPU data and no CPU data files.


Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.