Use at your own risk

Message boards : News : Use at your own risk
Message board moderation

To post messages, you must log in.

Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 . . . 19 · Next

AuthorMessage
Profile Martin Orpen

Send message
Joined: 30 May 17
Posts: 107
Credit: 24,487,190,676
RAC: 39,290,612
Message 219 - Posted: 2 May 2018, 19:31:55 UTC - in response to Message 201.  

Cheers Slicker -- thanks for the update... good luck with the GPU debugging.
ID: 219 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
David Riese
Avatar

Send message
Joined: 23 Sep 12
Posts: 82
Credit: 12,797,824,539
RAC: 35,804,184
Message 222 - Posted: 2 May 2018, 23:42:11 UTC

Slicker, I want to echo the thanks for the update. Good luck with the *n!x apps!
ID: 222 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Slicker
Project administrator

Send message
Joined: 11 Jun 09
Posts: 57
Credit: 943,644,517
RAC: 6,195
Message 237 - Posted: 4 May 2018, 21:49:27 UTC - in response to Message 199.  

Hello,

after detach/attach, the collatz work dir:

projects\boinc.thesonntags.com_collatz

stay empty, and my host (windows + ATI, ID:139469) can't download work:


First enable sched_op_debug in the cc_config so you can see if it is really asking for work (more than zero seconds requested) or not.
Second, make sure you have the AMD OpenCL driver installed. The Microsoft version likely won't work. Install the real one from AMD. There are no CAL/Brook+ applications, only OpenCL.
Third, An HD5700 is a pretty old GPU and I'm not certain it supports OpenCL. If it does, you will likely need to install some legacy drivers.
ID: 237 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Slicker
Project administrator

Send message
Joined: 11 Jun 09
Posts: 57
Credit: 943,644,517
RAC: 6,195
Message 238 - Posted: 4 May 2018, 21:56:04 UTC - in response to Message 222.  

Slicker, I want to echo the thanks for the update. Good luck with the *n!x apps!


And the testing continues.... Using the boost library is a no-go on *nix. At least not the multi-precision cpp_int.hpp as it is buggy. My custom 256 bit isn't working either. To get apps out the door faster, I'm reverting to using GMP to do the validation. It only validates when it finds a higher number of steps so the performance hit is very minimal as it only gets called a dozen times or so per workunit. I'll fix the bugs in my 256 bit code once things settle down.
ID: 238 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Tetsuji Maverick Rai

Send message
Joined: 19 Apr 18
Posts: 10
Credit: 3,670,214,811
RAC: 9,058,885
Message 240 - Posted: 5 May 2018, 4:39:56 UTC - in response to Message 188.  
Last modified: 5 May 2018, 4:45:01 UTC

And the testing continues.... Using the boost library is a no-go on *nix. At least not the multi-precision cpp_int.hpp as it is buggy. My custom 256 bit isn't working either. To get apps out the door faster, I'm reverting to using GMP to do the validation. It only validates when it finds a higher number of steps so the performance hit is very minimal as it only gets called a dozen times or so per workunit. I'll fix the bugs in my 256 bit code once things settle down.


Thank you for explaining. I see that situation. I'll wait and see.

Regards,
Luckiest man in the world

ID: 240 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile ruidocarmo

Send message
Joined: 11 Apr 10
Posts: 4
Credit: 115,074,267
RAC: 80,527
Message 244 - Posted: 5 May 2018, 18:48:55 UTC

Hi!

Since the new version of Collatz I'm not receiving GPU work for my APU AMD A8-7600 (host 89107).

I think that is not a question of drivers because I installed the drivers from the AMD site...

I enabled sched_op_debug in the cc_config file and received the following messages:

05-05-2018 19:37:00 | collatz | sched RPC pending: Requested by user
05-05-2018 19:37:00 | collatz | [sched_op] Starting scheduler request
05-05-2018 19:37:00 | collatz | Sending scheduler request: Requested by user.
05-05-2018 19:37:00 | collatz | Requesting new tasks for AMD/ATI GPU
05-05-2018 19:37:00 | collatz | [sched_op] CPU work request: 0.00 seconds; 0.00 devices
05-05-2018 19:37:00 | collatz | [sched_op] AMD/ATI GPU work request: 33995.60 seconds; 1.00 devices
05-05-2018 19:37:01 | collatz | Scheduler request completed: got 0 new tasks
05-05-2018 19:37:01 | collatz | [sched_op] Server version 711
05-05-2018 19:37:01 | collatz | Project requested delay of 121 seconds
05-05-2018 19:37:01 | collatz | [sched_op] Deferring communication for 00:02:01
05-05-2018 19:37:01 | collatz | [sched_op] Reason: requested by project


Can anyone give me some hint to receive work again?

Many thanks
ID: 244 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile mikey
Avatar

Send message
Joined: 11 Aug 09
Posts: 489
Credit: 12,359,873,211
RAC: 10,284,835
Message 247 - Posted: 6 May 2018, 12:19:45 UTC - in response to Message 244.  

Hi!

Since the new version of Collatz I'm not receiving GPU work for my APU AMD A8-7600 (host 89107).

I think that is not a question of drivers because I installed the drivers from the AMD site...

I enabled sched_op_debug in the cc_config file and received the following messages:

05-05-2018 19:37:00 | collatz | sched RPC pending: Requested by user
05-05-2018 19:37:00 | collatz | [sched_op] Starting scheduler request
05-05-2018 19:37:00 | collatz | Sending scheduler request: Requested by user.
05-05-2018 19:37:00 | collatz | Requesting new tasks for AMD/ATI GPU
05-05-2018 19:37:00 | collatz | [sched_op] CPU work request: 0.00 seconds; 0.00 devices
05-05-2018 19:37:00 | collatz | [sched_op] AMD/ATI GPU work request: 33995.60 seconds; 1.00 devices
05-05-2018 19:37:01 | collatz | Scheduler request completed: got 0 new tasks
05-05-2018 19:37:01 | collatz | [sched_op] Server version 711
05-05-2018 19:37:01 | collatz | Project requested delay of 121 seconds
05-05-2018 19:37:01 | collatz | [sched_op] Deferring communication for 00:02:01
05-05-2018 19:37:01 | collatz | [sched_op] Reason: requested by project


Can anyone give me some hint to receive work again?

Many thanks


Try detaching from Collatz and reconnect using http:// NOT https://
ID: 247 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Daniel

Send message
Joined: 29 Oct 10
Posts: 8
Credit: 2,116,987,981
RAC: 2,677,452
Message 249 - Posted: 6 May 2018, 12:47:22 UTC - in response to Message 247.  
Last modified: 6 May 2018, 12:52:20 UTC

I am running Windows 10 with Nvidia GPUs and I also haven't been able to get any tasks since the new applications were released.
I have tried detaching and reconnecting using both http:// and https:// but can not get any tasks either way.
ID: 249 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile ruidocarmo

Send message
Joined: 11 Apr 10
Posts: 4
Credit: 115,074,267
RAC: 80,527
Message 250 - Posted: 6 May 2018, 13:34:58 UTC

I already attached Collatz using http:// but with no success getting new tasks...
It could be some issue related with the plan classes ATI/AMD stated in this topic?
ID: 250 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile mikey
Avatar

Send message
Joined: 11 Aug 09
Posts: 489
Credit: 12,359,873,211
RAC: 10,284,835
Message 254 - Posted: 7 May 2018, 10:11:26 UTC - in response to Message 249.  

I am running Windows 10 with Nvidia GPUs and I also haven't been able to get any tasks since the new applications were released.
I have tried detaching and reconnecting using both http:// and https:// but can not get any tasks either way.


Get rid of the "s" on the https:// and it will work, he hasn't setup the secure site yet.
ID: 254 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile mikey
Avatar

Send message
Joined: 11 Aug 09
Posts: 489
Credit: 12,359,873,211
RAC: 10,284,835
Message 255 - Posted: 7 May 2018, 10:14:37 UTC - in response to Message 250.  

I already attached Collatz using http:// but with no success getting new tasks...
It could be some issue related with the plan classes ATI/AMD stated in this topic?


I have no clue then as my AMD gpu's are working just fine right now. Are you using an app_config.xml file? If so rename it to something else and try again.
ID: 255 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Daniel

Send message
Joined: 29 Oct 10
Posts: 8
Credit: 2,116,987,981
RAC: 2,677,452
Message 258 - Posted: 7 May 2018, 11:38:15 UTC - in response to Message 254.  

Hi Mikey,

I've already tried connecting to http://boinc.thesonntags.com/collatz/ but I still can't get any tasks.

I always get the same message ...

7/05/2018 9:36:39 PM | collatz | update requested by user
7/05/2018 9:36:40 PM | collatz | Sending scheduler request: Requested by user.
7/05/2018 9:36:40 PM | collatz | Requesting new tasks for NVIDIA GPU
7/05/2018 9:36:44 PM | collatz | Scheduler request completed: got 0 new tasks
ID: 258 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile step2000
Avatar

Send message
Joined: 1 Aug 13
Posts: 16
Credit: 4,358,093,135
RAC: 6,055,442
Message 260 - Posted: 7 May 2018, 18:03:20 UTC - in response to Message 258.  

Do you have the run-time c library for 32/64 bit versions install?
Just me being a Math Geek!
ID: 260 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile ruidocarmo

Send message
Joined: 11 Apr 10
Posts: 4
Credit: 115,074,267
RAC: 80,527
Message 261 - Posted: 7 May 2018, 19:26:39 UTC - in response to Message 255.  

I have no clue then as my AMD gpu's are working just fine right now. Are you using an app_config.xml file? If so rename it to something else and try again.


No app_config file.
I detached again the project, reinstalled the AMD drivers with a clean install and updated the Visual C++ 2017 x86 and x64 but no work at all for the AMD GPU...

It's weird, because everything went well before the update in Collatz, but I will let boinc ask for work and wait a bit more...
ID: 261 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Daniel

Send message
Joined: 29 Oct 10
Posts: 8
Credit: 2,116,987,981
RAC: 2,677,452
Message 266 - Posted: 8 May 2018, 9:04:35 UTC - in response to Message 260.  
Last modified: 8 May 2018, 9:08:39 UTC

Hi step2000,

I have the following installed ...
Microsoft Visual C++ 2008 Redistributable - x64
Microsoft Visual C++ 2008 Redistributable - x86
Microsoft Visual C++ 2010 Redistributable - x64
Microsoft Visual C++ 2010 Redistributable - x86
Microsoft Visual C++ 2012 Redistributable - x64
Microsoft Visual C++ 2012 Redistributable - x86
Microsoft Visual C++ 2013 Redistributable - x64
Microsoft Visual C++ 2013 Redistributable - x86
Microsoft Visual C++ 2015 Redistributable - x64
Microsoft Visual C++ 2015 Redistributable - x86

I haven't installed or uninstalled any software recently.
The PC is as it was before the new applications were released and previously I was able to get tasks.
The only thing I've done is disconnect and reconnect to the project.

Edit : I see the project now requires Microsoft Visual C++ Redistributable for Visual Studio 2017. I'll install it and see what happens.
ID: 266 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Daniel

Send message
Joined: 29 Oct 10
Posts: 8
Credit: 2,116,987,981
RAC: 2,677,452
Message 267 - Posted: 8 May 2018, 9:26:13 UTC - in response to Message 266.  
Last modified: 8 May 2018, 9:50:44 UTC

I've installed the Microsoft Visual C++ Redistributable for Visual Studio 2017 (x86 and x64 versions) but I still don't get any tasks.

Edit :
I've tried enabling sched_op_debug in Boinc Manager and I can see that it is requesting work ...
8/05/2018 7:43:29 PM | collatz | [sched_op] NVIDIA GPU work request: 301279.96 seconds; 3.00 devices

I've also checked that "Use NVIDIA GPU" is ticked in Collatz Conjecture preferences.
ID: 267 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile step2000
Avatar

Send message
Joined: 1 Aug 13
Posts: 16
Credit: 4,358,093,135
RAC: 6,055,442
Message 272 - Posted: 8 May 2018, 14:45:32 UTC - in response to Message 267.  

Delete the Project and Add back in maybe.
Just me being a Math Geek!
ID: 272 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jammassinia

Send message
Joined: 16 Oct 15
Posts: 6
Credit: 3,180,305,500
RAC: 0
Message 273 - Posted: 8 May 2018, 19:56:40 UTC - in response to Message 1.  

I'm testing the validator, work generator, assimilator, and applications. It may or may not work which means you may or may not get credit for your work. There is still a lot of work to do but I'm making progress.


Hi Jon,

Started to notice CPU work units are finally beginning to validate, some inconclusive and some validating fine.

However, the ones which have validated fine give no credit at present.

Is this still on the to do list?




Thanks as always for all the work you're putting in!

Jack
ID: 273 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Daniel

Send message
Joined: 29 Oct 10
Posts: 8
Credit: 2,116,987,981
RAC: 2,677,452
Message 277 - Posted: 9 May 2018, 8:53:04 UTC - in response to Message 272.  

Hi step2000,

I've just tried removing the project and adding it again, but still no luck getting tasks.
ID: 277 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
mmonnin

Send message
Joined: 29 May 16
Posts: 14
Credit: 502,516,136
RAC: 5
Message 279 - Posted: 9 May 2018, 13:10:21 UTC

I don't think a missing VS.net would prevent tasks from downloading anyway. They may abort if its required and missing though.
ID: 279 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Previous · 1 · 2 · 3 · 4 · 5 · 6 · 7 · 8 . . . 19 · Next

Message boards : News : Use at your own risk


©2019 Jon Sonntag; All rights reserved