Posts by jjwhalen
log in
1) Message boards : Number crunching : Database error. unable to upload (Message 22156)
Posted 666 days ago by jjwhalen
Cool.
2) Message boards : Number crunching : Database error. unable to upload (Message 22148)
Posted 666 days ago by jjwhalen
It's been a long time (for this project) since the database crashed. The nightly maintenance seems to be doing a good job.

My RAC almost hit 800,000 this time. Curses! Foiled again! :)
3) Message boards : Number crunching : Server outages (Message 21840)
Posted 767 days ago by jjwhalen
but GPUGrid is particular is something of a sticking point -- the work units there run between 22 and 36 hours or so and have short deadlines.


It also doesn't help that GPUGRID currently has little to no work available - mostly the latter. Personally I use Primegrid/PPS Sieve as my GPU reserve project. It has infinite numbers to evaluate, and server uptime is well above 99%. But whatever works for you.
4) Message boards : Number crunching : dead? (Message 21762)
Posted 792 days ago by jjwhalen
It's good to be back after a short vacation from Collatz.

After the Win10 update, I was able to use the free GPU-Z.exe to see that OpenCL was missing or broken. The next NVIDIA driver update (359.00) restored it.
5) Message boards : News : Sieve in Production; Large and Solo deprecated (Message 21496)
Posted 832 days ago by jjwhalen
No more work, plus the validator has gotten stalled again.

Makes be (sic) glad I've alternative GPU projects for the four Collatz GPU systems.


Amen to that ;)
6) Message boards : News : Sieve in Production; Large and Solo deprecated (Message 21470)
Posted 834 days ago by jjwhalen
Somebody turn the Sieve Work Generator back on please.

P.S., And maybe reboot the server while you're at it.
7) Message boards : News : Sieve in Production; Large and Solo deprecated (Message 21437)
Posted 838 days ago by jjwhalen
Slicker,

1. The Sieve Work Generator seems to be offline ~50% of the time these days. Is this by design or is it a fixable problem?

2. Also the website has been extremely sluggish the past couple of days (e.g., I've been trying without success to update the Server Status for the past 25 minutes). Is this due to the ongoing battle with your ISP that you've discussed elsewhere in this forum?

3. The validator backlog is approaching 4000.
8) Message boards : Number crunching : Sieve work generator is down (Message 21282)
Posted 861 days ago by jjwhalen
The work generator just went down and the 'unsent' queue is empty.

<Edit> Back up quickly.
9) Message boards : Number crunching : Validator broken (Message 21270)
Posted 864 days ago by jjwhalen
The validation queue is getting rather large. Do we know how long the sieve validator will be offline?


OK, now the validator is up and the assimilator is down...progress.
10) Message boards : Number crunching : Validator broken (Message 21267)
Posted 864 days ago by jjwhalen
The validation queue is getting rather large. Do we know how long the sieve validator will be offline?
11) Message boards : News : Collatz Sieve v1.21 released for Windows (Message 21216)
Posted 868 days ago by jjwhalen
Slicker,

The VS2012 C++ runtime seems to do the trick. Early returns show 1.21 to be 20-25% faster than 1.10 at the same GPU clock speed (910MHZ) on my GTX580.

I also notice that the CPU:Run time ratio of v1.21 is virtually nil (<1 sec) despite the fact the plan class still calls for 0.816 CPU + 1 NVIDIA GPU. More like CUDA than OpenCL.

Thanks for the workaround.
12) Message boards : News : v1.20 sieve apps have been deprecated due to validation failures (Message 21212)
Posted 868 days ago by jjwhalen
While the app runs great (except on OS X with AMD GPUs -- as usual), the WUs are failing to validate so I have deprecated the 1.20 version and am in the process of debugging the issue and hope to have a 1.21 version ready soon.


Congrats on quick roll-out of v1.21. Unfortunately my Win64 version on computer ID23085 is failing similarly to 1.20 after (milliseconds) with the same exit code:
-1073741515 (0xffffffffc0000135) Unknown error number

I can't agree that 1.20 "ran great" on my system, or even at all. I completed well over 4000 1.08 & 1.10 WUs, with an error rate something like .1%.
13) Message boards : News : Micro Collatz CPU Apps (Message 19354)
Posted 1357 days ago by jjwhalen
I have my 2 Androids assigned to the Work identity, with only Mini & Micro selected, & with "accept work from other applications" set false. (Which shouldn't matter as long as there is Mini/Micro work available.) I've yet to try selecting Micro only for the Androids but will do so.
14) Message boards : News : Micro Collatz CPU Apps (Message 19351)
Posted 1357 days ago by jjwhalen
Good idea; what about Android/ARM? The Applications list indicates it is available as of 24 Apr, though so far I've only received Mini on my Androids.
15) Message boards : News : Missing Apps (Message 19262)
Posted 1363 days ago by jjwhalen
I'm still only getting Mini w/u's. (I actually did receive 3 Solo tasks 1 time only.) But I see that the unsent queue of Solo is now remaining at zero, presumably due to excessively high demand. I can only guess that the server load must be very high with all these short w/u's on fast GPUs. My overclocked GTX580 runs Mini in <4 min.

I agree with the spirit of mfc's post, but I wouldn't want to see it hard-coded on the server end. Better that each user set up separate Preferences for ARM, CPU only or GPU machines as needed.
16) Message boards : News : Missing Apps (Message 19251)
Posted 1364 days ago by jjwhalen
Computer ID 23085:

With only Solo Collatz & CUDA nVidia selected, I am unable to get new work, despite Server Status showing 350+ Solo available.

With Solo Mini & Micro selected, I am able to d/l Mini. At least Mini is my second choice.
17) Message boards : News : Back Online (Message 18630)
Posted 1433 days ago by jjwhalen
Tsk Tsk. You have to replace/recycle those UPS batteries once a year whether you think they need it or not. I speak from bitter experience.
18) Message boards : News : CUDA vs nVidia OpenCL User Poll (Message 18594)
Posted 1435 days ago by jjwhalen
Option a) for me.
19) Message boards : News : CUDA 3.1 Application Available for Windows (Message 9458)
Posted 2699 days ago by jjwhalen
Forgot to ask:

If you install the power app and later reset the project, will you then have to go back and manually reinstall again?
20) Message boards : News : CUDA 3.1 Application Available for Windows (Message 9429)
Posted 2700 days ago by jjwhalen

Any 2.04 apps will show 2.04 even though it is running 2.05. Once the previously downloaded WUs are completed, it will show 2.05. That's the reason why the app_info.xml contains sections for previous versions. It keeps BOINC from aborting the previously downloaded WUs because it doesn't think it has the right app. When it downloads new work, it uses the highest version number and that's why new WUs will show up as 2.05.


I'm slightly confused. I traded up from v2.03 on my ComputerID 23085, a Win7_x64/Fermi GTX 465SC, (overclocked ~15% -- GPUGRID won't tolerate much higher). v2.05 installed OK, according to the readme. The confusion factor: the app_info.xml I got doesn't contain any section for the older version. v2.03 and its WUs were summarily dumped when I restarted the client. This must look to the server like the project was Reset (not WUs Aborted), because the WUs were immediately resent under the "lost children" rules.

v2.05 appears to be running fine (thanks, developer ;D ). Using the default options in the app_info.xml as provided, it appears to run 15-18% faster on my Fermi than v2.03_x64 did.

I notice that reported results are showing up in the server database as "Anonymous platform," not cuda 31. Normal, or glitch?

Minor oops in the readme: its internal title is
Collatz 2.04 CUDA Optimized Application Readme
(Yes, I definitely got the 2.05 .exe) ;)




Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.