Posts by kashi
log in
1) Message boards : Number crunching : Tasks marked as invalid, and pending tasks marked as validation inconclusive? (Message 12221)
Posted 2463 days ago by Profile kashi
Temps look OK. 3 GPUs make for a powerful looking, mean crunching machine. Limited space between GPUs would possibly cause problems for me here in summer but it appears to be working fine for you, temperature wise. CPU speed seems low, perhaps that is some power saving feature downclocking the CPU.

I don't think 3) new version of BOINC Manager would be causing the problems. However:

1) Catalyst 11.2 is known to have caused problems for some.

2) CF has been known to cause problems with both being able to process tasks at all and errors such as those resulting from ULPS shutting down second GPU core and causing phantom GPU cores to be created by BOINC. This can differ depending on OS and number of monitors. Some get CF to work for BOINC, others require no CF and a dummy plug. Disabling ULPs in registry may sometimes help when CF is being used. May require patient experimentation until a stable working setup can be found. People are sometimes not aware that it is necessary to ensure correct operation when monitor is switched off as this is when sleeping GPU core/phantom GPU core problems are more likely to happen in my experience.

4) Win 7 may cause problems compared to Windows XP. This relates to whether an additional monitor or a dummy plug is required for Windows to recognise more than one GPU. CF allows both GPUs to be recognised in Win 7 but may cause its own problems as in 2). Win 7 may also cause errors when attempting to create the buffer for Collatz ATI GPU tasks due to higher memory usage by Win 7. This mainly affects a few with multiple GPUs and 4GB or less of system memory. Your invalid tasks are not showing the buffer error message though so this is not affecting you currently.
2) Message boards : Number crunching : Tasks marked as invalid, and pending tasks marked as validation inconclusive? (Message 12218)
Posted 2464 days ago by Profile kashi
Notice how the core/memory speeds are shown as 1000/1250 MHz when there are 4 GPUs shown in Stderr output. I think Catalyst 11.2 caused this for some people. It was fixed in Catalyst 11.4. Catalyst 11.4 is a beta and was released before Catalyst 11.3 so I don't know if Catalyst 11.3 also has the incorrect speed fix.

As for the 2 phantom GPUs, I sometimes got these phantoms when turning off the screen. It causes 2 tasks to run concurrently on each GPU core and other problems such as using too much system memory to create the buffers for 4 tasks. I struggled with it for quite a while until I resolved it with the use of a dummy plug. I used 2 actually because I had 3 GPU cores.

You can see from the Stderr output of the invalid results that sometimes 4 GPUs are detected and sometimes 2. When 4 are detected the core/memory speeds are incorrect for all 4. When 2 are detected speeds are correct but BOINC is trying to assign the task to Device 2 or Device 3 which are not available.

So firstly you could try Catalyst 11.4 and see if it fixes your incorrect speed issue.

I cannot advise you on how to fix the phantom GPU issue when using crossfire. If you wished you could try disabling crossfire and using a dummy plug or not turning your screen off if this is what is causing your phantom GPUs.

You could also try changing all instances of EnableULPS in the registry from a value of 1 to a value of 0. It's some weird powersaving thing which causes GPUs to downclock or the second one of a crossfire pair to sleep when idle, but they sometimes don't wake up again when needed to crunch tasks. This can lead to BOINC creating phantom GPU cores, 2 tasks running concurrently on one GPU core, tasks struggling to run on a downclocked GPU core, screen sluggishness, etc..
3) Message boards : Number crunching : System Freezes When Running Collatz (Message 12128)
Posted 2471 days ago by Profile kashi
I don't know about other users and reviews but from the bangkokimages review linked by Zydor "I tightened mine to take up about 35-40% of the threads. No more."

That was interesting in the other review about the large improvement using thermal paste instead of the thermal pad on the VRM heatsink. I wonder if many users have done this. I notice also that they adjusted the fanspeed to 1,920rpm. I remember reading another review where they left fanspeed on auto and the VRM temps under load got far too hot, so they had to increase the speed manually.

Thanks for the review links, it has inspired me to install mine which I bought direct before it was in the shops.

Gas Giant, wow 4489rpm , must sound almost ready for takeoff, haha. Your temps are not too hot now, although uneven and VDDC current looks rather high to me.
My 5970 @ 760/500 on MilkyWay:

4) Message boards : Number crunching : System Freezes When Running Collatz (Message 12109)
Posted 2472 days ago by Profile kashi
Opinions vary on a safe VRM temperature. Even though the card should throttle if it overheats, personally I would consider 128 °C too hot. With a 5970, although I watch the core temps to give a general indication, it's mainly the VRM temps I am concerned about. Due to the 5970 cooling design one set of VRMs get very hot when under constant load such as crunching. Some gamers would be aghast at the thought of running Furmark constantly 24 hours a day and yet crunching can draw a similar or even higher amount of current on the voltage regulators.

I try to keep VRM temp below 100 °C by using a higher fan speed profile in Afterburner. It's noisier but effective. Crunching MilkyWay, it is currently a relatively cool 21 °C here, side of case off, GPU fan is at 3294rpm, core/memory is 760/500. GPU cores are 72 °C and 69 °C, hottest VRM is 84 °C. This is a bit lower than previously due to the new Milkyway application processing the likelihood at the end on the CPU.

Although GPU memory and the VRMs that supply it are the likely cause, your problems may also be voltage/temperature related because you are overclocked. My 5970 at default voltage starts giving errors on the second core at 810 MHz on MilkyWay, even with memory at 500 MHz. I have no experience with overvolting core and memory on GPUs so cannot advise. Lower speed on both core and memory and then a gradual increase is all I could suggest as a method of troubleshooting. Lower VRM temp also by increased fan speed and/or better case ventilation wouldn't go astray either.
5) Message boards : Number crunching : Extra load on Collatz (Message 12107)
Posted 2472 days ago by Profile kashi
Don't know if it's related but I occasionally have download/upload issues when my ISP uses a transparent proxy. They used to use one all the time. They claim to never use one now but sometimes they do. Strangely it may affect one project and not others, used to happen on Rosetta@home a while ago and recently affected another of my projects but I can't remember which one.

When this happens I need to use <http_1_0>1</http_1_0> option in a cc_config.xml file.
6) Message boards : Number crunching : System Freezes When Running Collatz (Message 12104)
Posted 2472 days ago by Profile kashi
I had the same on Catalyst 10.4. Previously I had blamed switching to an APP driver version at one stage but I was incorrect. It is related to memory on my 5970. When I tried Collatz at default core/ memory of 725/1000 I had those symptoms. When I tried at 725/500 I didn't get the little squares but the number of steps were too high so some of the first few tasks were invalid, not sure but I think only on the the second core. After those first few errors it started to work again without error. I tried it a few more times gradually raising the memory speed. I ended up at core/memory of 760/700. I didn't go higher on memory because I had BOINC configured to switch back to MilkyWay when work became available. I haven't experimented further.

I think the memory or the voltage regulator is either damaged or has become used to running at 500 for a long time on MilkyWay and DNETC. So when switching back to Collatz where the memory is used more intensively it produces screen artifacts or errors, especially if you increase the memory speed above what you were using on the other GPU projects.

So you could try using a very low memory speed and gradually raising it a little at a time to try and get the juice flowing properly again to the memory. Like a burn in process I suppose. While doing this watch that the number of steps are in the correct range and not extremely high (probably mainly on the second core). I only tried mini Collatz tasks with this. When I had tried the long Collatz tasks previously my computer froze so when I tried it again I only tried the shorter mini Collatz tasks. Good luck.

7) Message boards : Number crunching : Possible Problem with Catalyst 11.2 (Incl APP) (Message 11654)
Posted 2515 days ago by Profile kashi
.....However, the second I turn the cards back onto Collatz, small square artifacts pop up all over the screen, and the system becomes entirely unresponsive. I have to do a hard reset to get it going again. And this ONLY happens with Collatz.

@Kashi: is this the symptom you get when you put your 5970 on Collatz?

Yes that was the exact symptoms I experienced. Little coloured squares all over the screen and total lockup as soon as Collatz tried to start. That was a fair while ago now and I had forgotten about the little squares until you mentioned them.

Thought my 5970 was broken and was relieved when MilkyWay and DNETC worked without error. Didn't wish to experience that drama again so haven't tried Collatz since.

I had supposed that perhaps the memory on my 5970 would no longer work at default 1.000 MHz but can still cope with 500MHz on MilkyWay and DNETC. Not certain if that is the case though. Also thought it may have been extra memory load because of the longer Collatz tasks. Thought it couldn't be heat related because it happens instantly when Collatz tries to start and DNETC runs much hotter than Collatz anyway. Decided to get my 100 million at DNETC before I investigated further. Will check it out further in a few weeks when the current Aussie Assault 25 is over.
8) Message boards : Number crunching : BSOD Running any cuda23 wu (Message 11567)
Posted 2521 days ago by Profile kashi
I see, thanks for the clarification. Seems strange to have a different meaning for NVIDIA compared to ATI/AMD.

I have only ATI cards so not qualified to comment, just noticed the different "count" value so thought I would mention it as a possible source of trouble.

I remember the server would not send ATI work with configuration of 2 tasks running on one card (0.5 count value, a fraction). I thought perhaps the count value of 2 (a multiple) may somehow be causing 2.03 application to be sent rather than 2.05 or otherwise causing problems.
9) Message boards : Number crunching : BSOD Running any cuda23 wu (Message 11560)
Posted 2522 days ago by Profile kashi
<count>2</count> would arouse my suspicion if I saw it anywhere relating to my ATI HD 5970. I believe that would mean attempting to run one task on two GPUs. Don't know what it means for CUDA though but arkayn's file shows <count>1</count>.
10) Message boards : Number crunching : Possible Problem with Catalyst 11.2 (Incl APP) (Message 11557)
Posted 2522 days ago by Profile kashi
Wouldn't be surprised if this only affects those running HD 5970 and perhaps also multiple cards with crossfire enabled. You will notice that the core/memory speeds initially reported are OK (860/1210) when the tasks commence on one GPU core. It is only when they are offloaded to another GPU core that they increase to 1,000/1,500.

A few months ago my HD 5970 had trouble with Catalyst 10.11 APP on MilkyWay causing invalids only on the 2nd core. Very strange. I posted on the MilkyWay forum but nobody with a HD 5970 replied that they had noticed the same thing.

I removed 10.11 APP completely with Driver Sweeper and installed 10.4 and all was well again at MilkyWay. Couldn't run Collatz at all though, it caused instant freeze of computer every time a Collatz task started even at default 725/1,000 core/memory. Haven't tried Collatz again since but Milkway and DNETC have given no errors at 760/500 on Catalyst 10.4.

I had installed 10.11 APP version driver to test out PrimeGrid's OpenCL application after someone mistakenly reported that it was running successfully on their HD 5970. Of course it didn't work properly, but the tasks completed and reported OK so I didn't notice immediately but only after the tasks completed on the second core were finally marked invalid a few days after first being marked inconclusive.

OpenCL is not supported on both cores of a HD 5970, others are free to choose any driver version they wish but I would never again consider installing a Catalyst version with APP included. My HD 5970 can't use OpenCL anyway so I see no benefit to installing unnecessary software and risking potential problems.

Before anyone states that ATI/AMD GPU applications for Collatz, MilkyWay and DNETC are CAL/Stream and not OpenCL, so an OpenCL Catalyst APP version driver can have no effect on these applications, I will just state that this has not been my experience with my 5970.
11) Message boards : Number crunching : "Message from server: collatz _("is not available for your type of computer")." (Message 11522)
Posted 2525 days ago by Profile kashi
I know nothing of Macs but if your MacOS X 10.6.6 is a 64-bit operating system there are no 64-bit Mac CUDA applications shown as available and perhaps the server will no longer send you the collatz or mini_collatz 2.2 (cuda) versions.

The reason for this is possibly because recently Slicker has edited the server code to now only send 64-bit applications to hosts with 64-bit operating systems. This was necessary due to a flaw/feature in the BOINC server code that caused 32-bit applications to be sent to 64-bit hosts when this was not desired by the contributors or the project. In your case you may require this as it appears there are no suitable 64-bit CUDA applications for your operating system.

This is only a possibility, Slicker will know more about this than the little I do. Dealing with BOINC server code is thankfully not my area of experience.
12) Message boards : Number crunching : need help / Linux 32-bit ATI (Message 11512)
Posted 2525 days ago by Profile kashi
You could try using Catalyst version 9.4 or 9.2, Catalyst versions 9.5 and higher sometimes fail when 1D Streams are larger than 8192.

This is just a suggestion for you to try. It may not work. I know nothing about this area myself, it is only something I read in an old cached message thread on the AMD Developer forum.
13) Message boards : Number crunching : Error out creating buffer (Message 11389)
Posted 2536 days ago by Profile kashi
I'm glad it worked for you. According to reports using a smaller buffer makes very little difference to the speed of processing Collatz tasks.

As to why it actually needs so much more free memory than it should in Windows 7 to create the buffer I have no answer. Possibility is that it uses some multiple of the buffer amount when the buffer is being created and not just the 256MB. Either that or Windows 7 uses some free memory as some form of cache that is not shown in Task Manager and doesn't reassign it properly or quickly enough when a Collatz GPU task starts.

I also use Windows 7 and I remember the hard disk started thrashing on some early RNA World tasks that used a large amount of memory. There was still some free memory shown at that time so apparently with Windows 7 you may not have as much usable free memory as Task Manager shows.
14) Message boards : Number crunching : Error out creating buffer (Message 11385)
Posted 2536 days ago by Profile kashi
I know it sounds illogical but checking how much memory is being used in Task Manager doesn't always indicate that enough is available to create the buffer. "The ATI app will use 33% of the cards RAM which requires the same amount of system RAM to copy the data to/from it in addition to the app footprint and texture memory (another 30MB or so)".

So you would think that 2GB would be sufficient but the combination of Windows 7 and Collatz has caused this same buffer error in the past even with someone that had 3GB of system memory. They were using 2 HD 5850s, but the principle is the same. 3GB should have been enough in theory, but it was not enough to avoid the buffer error.

You could be right and it is something else, but going on the experience of a number of people over the years I would say insufficient system memory combined with Windows 7 is the most likely cause.

If you are interested here is a suggested fix I have posted a number of times in such cases:

Possible solutions:

1. Install additional memory in computer.

2. (For 64-bit Windows OS and Catalyst driver 9.2 and above)
Download and install (follow instructions in readme file) "Win64_2.09_ATI.zip (Win64 ATI with ATICALxx.DLL files)" from Power (Optimized) Applications page. Set <cmdline>r25</cmdline> in app_info.xml file. Test and see if amount of GPU memory allocated to step array has been reduced from 256MB to 128MB (see this in stderr out section of task details). It may be necessary to reduce r parameter further to reduce GPU memory allocated to step array to 64MB. If there is still not enough memory available after that to create the buffer there may be no other option but to install more system memory or continue to use Windows XP.

These are just suggestions you may wish to try, hopefully one of them will work for you or the cause may be something else as you suggested.
15) Message boards : Number crunching : Error out creating buffer (Message 11382)
Posted 2536 days ago by Profile kashi
Windows 7 uses more memory than XP. With 2GB of system memory you are probably running short when attempting to run Collatz GPU tasks on Windows 7.
16) Message boards : News : Mini Collatz App Released (Message 11358)
Posted 2538 days ago by Profile kashi
Ah I see, the ATI/AMD optimised applications are the same as the default until the parameters are altered. I didn't realise the CUDA optimised applications are different from the default.

Also didn't think of any tasks in cache, I usually always finish any tasks on hand before installing an app_info.xml.

So yes, disregard my suggestions, they were based on an incorrect assumption. I was just trying to make it easier.

I was about to suggest an app_info.xml containing both collatz and mini_collatz applications to prevent any trouble if swapping between the 2 different sized tasks. Then I thought better of it because it may possibly just bamboozle myself and everyone else at this stage.
17) Message boards : News : Mini Collatz App Released (Message 11355)
Posted 2538 days ago by Profile kashi
Wouldn't you also need to rename every instance of "collatz_2.05_windows_intelx86__cuda31.exe" to "mini_collatz_2.05_windows_intelx86__cuda31.exe" and also rename the executable itself?

Your app_info.xml seems to have the default parameters, so why do you need it? Perhaps it would be easier to get rid of your app_info.xml file by detaching from the project, adjust your Collatz Conjecture preferences to Run only the selected applications mini_collatz and then attach again. This should download the correct application and matching files for you automatically. Much quicker and easier, no mucking around with app_info.xml necessary and less chance of making an error when trying to configure things.

This is what happens with an ATI/AMD card. NVIDIA cards should be automatically recognised in a similar manner I would think. Not sure as I don't have one, feel free to correct me if I am wrong.
18) Message boards : Science : Pending WU's (Message 11018)
Posted 2561 days ago by Profile kashi
Not lost, still pending. Most pendings clear within a few days to a week when the wingman completes the task. Some people stop processing Collatz tasks and detach without first aborting the tasks still in their cache or abort them after 14 days. Either way this means that after 14 days those tasks are then reissued and so begin another potential 14 day cycle. In my experience only a very small percentage of tasks remain pending after 2 full cycles or 28 days. This kind of thing happens in all projects that have a quorum and a longish report deadline. Some CPU only projects with a similar report deadline have a much higher percentage of tasks that stay pending for more than one cycle.

Sometimes after there has been some downtime in a project , there can be an increase in the amount of pending because some who have switched to another project during the downtime just report those tasks they have completed when the project server is running again and then detach from the project without first aborting unfinished tasks in their cache.
19) Message boards : Number crunching : 6850 performance? (Message 10708)
Posted 2585 days ago by Profile kashi
Yes new cards sometimes cause identification issues. The ATI applications here and at MilkyWay also give incorrect details for Cayman series because they multiply by 5 for the VLIW instead of 4.

Hence for the 6970: 1920 shader units organized in 24 SIMDs with 16 VLIW units (5-issue)

instead of: 1536 shader units organized in 24 SIMDs with 16 VLIW units (4-issue)

Doesn't make any difference to how they work of course, just a cosmetic issue.
20) Message boards : Number crunching : /AMD x2 5000+ and HD5770 erroring out every WU (Message 10492)
Posted 2611 days ago by Profile kashi
Glad you got it working.

Yes Win XP 64 is more suitable than Win 7 for a computer with 1GB of ram, especially when using a video card with 1GB of video memory.

From memory Win XP 64 on my computer performed slightly faster on some CPU projects than Win 7 64. The only reason I swapped to Win 7 was because there was no Win XP Catalyst/CAL version for my HD 4890 that allowed stable GPU processing at the time.


Next 20

Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.