Posts by eXtreme Warhead
log in
1) Message boards : Number crunching : Locked Out (Message 23325)
Posted 439 days ago by Profile eXtreme Warhead
In the same boat. Just tried to do a "Reset Project" earlier and my BOINC client is unable to access the project servers. Going to suspend this project for the time being.

simple: use the http instead of https adress manually
2) Message boards : Number crunching : Longer Sieve WUs (Message 23324)
Posted 439 days ago by Profile eXtreme Warhead
As long as the credit per WU is proportional, I see no problem....


i only can speak about the nvidia wu, because my amd does not get any wus, i will have no problem with this. older cards with 2h on a 6970 (so my 5850 will take much longer for that) runtime isn't too bad...thats ok i think
3) Message boards : Number crunching : Failing WU's (Message 23276)
Posted 440 days ago by Profile eXtreme Warhead
every single cpu wu does crash after you paused the calculation and start it later again. it crashes then immediately...

could be the same as here: https://boinc.thesonntags.com/collatz/forum_thread.php?id=1445#23062
4) Message boards : Number crunching : Not getting tasks for GPU (Message 23275)
Posted 440 days ago by Profile eXtreme Warhead
09.11.2016 05:05:00 | | OpenCL: AMD/ATI GPU 0: ATI Radeon HD 5800/5900 series (Cypress/Hemlock) (driver version 1800.11 (VM), device version OpenCL 1.2 AMD-APP (1800.11), 1024MB, 991MB available, 4176 GFLOPS peak)
09.11.2016 08:49:54 | Collatz Conjecture | [sched_op] AMD/ATI GPU work request: 1728000.00 seconds; 1.00 devices
09.11.2016 08:50:00 | Collatz Conjecture | Scheduler request completed: got 0 new tasks

same thing here with everything that could be the problem isn't the problem...only my nvidias get proper work, not the amd on the same system...
5) Message boards : Number crunching : Umm... So... What happened over the holidays? (Message 20160)
Posted 1112 days ago by Profile eXtreme Warhead
I'm absolutely with you. the permanent down times are not acceptable. and those very long uninformed ones break those projects the neck.

i only will do another wu until i will hit 20mio and then go forever. this is ridiculous.
6) Message boards : Number crunching : Happy New Year! (Message 20158)
Posted 1112 days ago by Profile eXtreme Warhead
what was happened?

since xmas was the server down and i thought, that all wu are useless, because they only were active till 9.1.15 and finally on the 7.1.15 the servers are back up running...
7) Message boards : Number crunching : Mixed nvidia and AMD drivers (Message 20150)
Posted 1127 days ago by Profile eXtreme Warhead
with the right os it's not a problem to run both driver. look at my profile and you can see a 660ti and a hd5850 runs on the same win7...for linux you should google this, because i think it's possible there, too
8) Message boards : News : Have your cake and eat it too! (Message 18696)
Posted 1432 days ago by Profile eXtreme Warhead
compare the cuda and the opencl app at this time is fair, because, and that's the point: it gives the same amount of points. so for me cuda is much better

If you changed the OpenCL app to 6/17/6 it would be faster. But, it would still use more CPU.
how should this works with "more cpu" if the cpu is @opencl at a whole cpu-core for a wu and the app can't use two cores for one wu at a time?
9) Message boards : News : Have your cake and eat it too! (Message 18686)
Posted 1432 days ago by Profile eXtreme Warhead
Are you running GPU-Z whle running each to make sure that the GPU load remains the same whether running CUDA or OpenCL? If one is at 40% load and the other at 90% load with the default settings, it really isn't a fair comparison. Also, unless both are running the same WU, it isn't a fair comparison either since the WUs vary a little in length.


the gpu is everytime far above 95% because two wu running @same time and so the utilization for the gpu is about 97-99%. that's point 1. i see this the whole time i look on my desktop, thanks to the gpuobserver gadget

point 2 is, as everyone can see or not, don't know, that the time is shorter on cuda with a MASSIVE improvement on cpu-utilization @cuda. that's a fact.

actually two cudas parallel with 1 cpu-core each need about 3000-3500s with under 100s cpu for finalisation and two opencl ones parallel in the past were about 4000s with 4000s cpu also, still with a whole cpu core each.

i don't have to know about optimizations in the code with newer driver or the lenght of the wu. it is still a fact, that cuda is on my system faster und doesn't need the cpu anymore. thats the point i wanna told you...

further optimizations for collatz would be nice, but i need the system for the daily freetime and with those lines from above in the configfiles, the whole system is horrible laggy, so it's absolutely not useable on this system. i tested a bit around, but still with

threads=6
items_per_kernel=20
kernels_per_reduction=6

and even there were skipped frames in the videos. then cleared the config file and everything runs fine again. you can read this at the optimize thread: http://boinc.thesonntags.com/collatz/forum_thread.php?id=1117&postid=18623
10) Message boards : News : Have your cake and eat it too! (Message 18682)
Posted 1432 days ago by Profile eXtreme Warhead
as told in the other thread: it's not possible to run collatz with these settings on the nvidia, because the video gets "slimy". those optimizations runs perfectly on a hd5850, but those system is not my personal desktop and no one use it, so a possible video stuttering doesn't interest anyone ;)

the only thing i want to show was the difference between opencl and cuda on a 660ti and with it that the primegrid opinion isn't correct
11) Message boards : News : Have your cake and eat it too! (Message 18670)
Posted 1434 days ago by Profile eXtreme Warhead
gpu: 3,925.08s ......


Suggest you take a peek at your CPU setting, likely its at circa 0.05 (ish).

i gave the wu ONE whole cpu-core and not only 0,05...

if you mention the question in the other thread, i'm the one with the 660ti probably @stock config vs a faster, but optimized hd5850

appinfo looks like:
<gpu_versions>
<gpu_usage>0.5</gpu_usage>
<cpu_usage>1.0</cpu_usage>
</gpu_versions>


PS: runtimes from cuda-wu rised up to 3400s, but still only <100s cpu. and still this contradicts the info from the cuda/opencl poll-thread

Source of the below info : PrimeGrid Preferences :

CUDA is usually faster on pre-Kepler GPUs (GTX 5xx and older).
OpenCL is usually faster on Kepler GPUs (GTX 6xx and newer). Use whichever is faster.
12) Message boards : News : Have your cake and eat it too! (Message 18667)
Posted 1434 days ago by Profile eXtreme Warhead
gpu: 2,394.75s cpu: 95.55s points:7,285.78 solo_collatz v6.03 (cuda55)
gpu: 3,925.08s cpu: 3,868.61s points:7,323.67 solo_collatz v6.04 (opencl_nvidia_gpu)
no optimized apps, only two wu at the same time on a 660ti.

i think my choice for cuda was the right one...i don't think that opencl on nvidia has any advantages...
13) Message boards : News : Long Run-Times? Optimize. (Message 18623)
Posted 1436 days ago by Profile eXtreme Warhead
cc_config is empty, appconfig only set for two wu parallel. i only used the original version from the opt_config folder for the nvidia x64

tested now with items_per_kernel=18 and the mouse isn't laggy, but the video has some frequently skipped frames in it

tested a bit around and even with

threads=7
items_per_kernel=18
kernels_per_reduction=7

it has partially skipped frames. doesn't look like i can anything optimize about the original defautl values which are

threads=6
items_per_kernel=20
kernels_per_reduction=6

beecause without a nvidia config file it is perfectly smooth?

edit: checked it with
threads=6
items_per_kernel=20
kernels_per_reduction=6
and even there skipped frames. then cleared the config file and everything runs fine again. so what are the standardvalues?
14) Message boards : News : Long Run-Times? Optimize. (Message 18616)
Posted 1436 days ago by Profile eXtreme Warhead
does someone have a functionally optimized config for running collatz only on one 660ti so that the os isn't laggy as hell?

i took the optimizations from above on a system with a hd5850 and was able to improve the time per wu from 50min for one unit to 62min for two units. the problem on my normal pc is, that with the same settings the os is laggy as i couldn't be worse. even the cursor only jumps around :?

actually i use only the appconfig for two wu at the same time and be able to run 2wu in 68min. days ago my 660ti has needed ~35min and my 5850 about 50min, but now my 5850 is faster...
15) Message boards : News : CUDA vs nVidia OpenCL User Poll (Message 18555)
Posted 1439 days ago by Profile eXtreme Warhead
definitvely prefer cuda!




Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.