Posts by zombie67 [MM]
log in
1) Message boards : News : Collatz Sieve v1.21 Released for Linux and OS X (Message 21242)
Posted 861 days ago by zombie67 [MM]
Working!

Intel HD: http://boinc.thesonntags.com/collatz/result.php?resultid=21914262

nvidia: http://boinc.thesonntags.com/collatz/result.php?resultid=21914189
2) Message boards : News : Collatz Sieve v1.21 Released for Linux and OS X (Message 21235)
Posted 862 days ago by zombie67 [MM]
So how do I get 1.21? I downloaded those tasks after this thread was started, and I had test apps turned on.

Edit: Something weird is going on. Check out this task:

http://boinc.thesonntags.com/collatz/result.php?resultid=21811740

App version says 1.21. stderr says 1.20.

Same with the other two tasks I posted earlier in this thread.
3) Message boards : News : Collatz Sieve v1.21 Released for Linux and OS X (Message 21229)
Posted 862 days ago by zombie67 [MM]
Not validating.

intel: http://boinc.thesonntags.com/collatz/result.php?resultid=21808924

nvidia: http://boinc.thesonntags.com/collatz/result.php?resultid=21811346
4) Message boards : News : Collatz Sieve 1.20 released for Windows, Linux, and OS X (Message 21206)
Posted 863 days ago by zombie67 [MM]
Validate errors on my macs with intel and with nvidia. I have no config files set.

http://boinc.thesonntags.com/collatz/result.php?resultid=21732299

These tasks are failing to validate across all typed of OSs and GPUs too.

http://boinc.thesonntags.com/collatz/workunit.php?wuid=18461714
5) Message boards : Number crunching : Optimizing Collatz v6.xx OpenCL and CUDA Applications (Message 21182)
Posted 865 days ago by zombie67 [MM]
My 7970s on windows are getting only 50% load with the large app. So I tried the normal config file settings, that used to give me ~99 load in the past. But no change. Is there something different with these new apps?

<configuration>
verbose=0
items_per_kernel=22
kernels_per_reduction=9
threads=9
sleep=1
</configuration>
6) Message boards : Number crunching : Sieve: Intel HD? (Message 21181)
Posted 865 days ago by zombie67 [MM]
I am a-ok with mavericks or better.
7) Message boards : Number crunching : Sieve: Intel HD? (Message 21106)
Posted 879 days ago by zombie67 [MM]
I believe I read about the possibility of a sieve app for intel HD, which is great. But I am particularly interested in an app for OSX for intel HD, like there is for the other collatz apps. I have 6 machines that would like that very much.
8) Message boards : Number crunching : Optimizing Collatz Sieve (Message 20881)
Posted 907 days ago by zombie67 [MM]
I am using the following with my 7970s, and they are running at 99%. FWIW, I reserve a full thread per GPU.

verbose=0
kernels_per_reduction=9
threads=9
lut_size=12
sleep=1
reduceCPU=0
9) Message boards : Number crunching : No micro collatz tasks available (Message 20358)
Posted 1015 days ago by zombie67 [MM]
That is what the event log is telling me on my android device, even though server status page says there is plenty available.
10) Message boards : News : Collatz Back Online with Solo Collatz Only (Message 18838)
Posted 1406 days ago by zombie67 [MM]
Is there anything I can do to help? I could give you access to one of my machines if that would help. Heck, since it's a mac mini, I could just loan you one.
11) Message boards : News : Android Applications Now Available (Message 18770)
Posted 1412 days ago by zombie67 [MM]
Thanks for the info. Yes, my task is the smallest one (for now). I will abort it, and wait for even smaller tasks to be available.
12) Message boards : News : Android Applications Now Available (Message 18768)
Posted 1412 days ago by zombie67 [MM]
My GS3 has been running a task for 14 hours now, and is only 4% complete. If linear, that works out to 350 hours, or 14.6 days. The deadline is only 8 days, so it will be late.

Are the short or long solo tasks being issued to this app/android devices?
13) Message boards : Number crunching : Optimizing Collatz v6.xx OpenCL and CUDA Applications (Message 18601)
Posted 1430 days ago by zombie67 [MM]
An 8400GS has 16 stream processors. Sounds like the embedded Intel GPUs aren't much faster. From my experience, the 8400GS runs about the same speed as a quad core CPU, maybe 2-3 times faster if you don't mind sluggish response.


Okay, they appear to be similar GPUs, the HD 4000 and the 8400GS. FWIW, my macs with HD 4000 produce about 38k/day with the default settings. How do 8400GS cards on windows do with default settings? Optimized settings? I am trying to learn if I could do better with my macs, with optimized settings.
14) Message boards : Number crunching : Optimizing Collatz v6.xx OpenCL and CUDA Applications (Message 18445)
Posted 1435 days ago by zombie67 [MM]
There is no tool to monitor GPU load on OSX. Does anyone have suggested settings for the intel HD 4000? According to wiki, it has "16 execution units and additional features,[b] up to 332.8 GFLOPS at 1300 MHz".
15) Message boards : News : Collatz Back Online with Solo Collatz Only (Message 18434)
Posted 1435 days ago by zombie67 [MM]
Thanks Slicker! I appreciate all the hard work.
16) Message boards : News : Collatz Back Online with Solo Collatz Only (Message 18425)
Posted 1436 days ago by zombie67 [MM]

Thanks. That helped a little. I created a new version 6.05 which I hope will now return the actual reason why it doesn't want to compile the kernel. I purposely put a bug in the kernel (only while testing) and the build log showed the error on Mountain Lion so I hope it will work the same on Mavericks. I don't expect it work run, but I hope it will at least print out the actual error message now.


Here you go, a 6.05 task:

http://boinc.thesonntags.com/collatz/result.php?resultid=136916

Stderr output

<core_client_version>7.2.39</core_client_version>
<![CDATA[
<message>
process exited with code 245 (0xf5, -11)
</message>
<stderr_txt>
Collatz Conjecture v6.05 OS X x86_64 for OpenCL
Based on the AMD Brook+ kernels by Gipsel
Read config error: Cannot locate collatz.config
Platform: ADVANCED MICRO DEVICES
Device: 0x1021b00
OpenCL context created
OpenCL command queue created
OpenCL program created
[CL_DEVICE_NOT_AVAILABLE] : OpenCL Error : Error: Build Program driver returned (518)
Break on OpenCLErrorBreak to debug.
OpenCL Warning : clBuildProgram failed: could not build program for 0x1021b00 (ATI Radeon HD 6630M) (err:-2)
Break on OpenCLWarningBreak to debug.
[CL_BUILD_ERROR] : OpenCL Build Error : Compiler build log:
Error returned by cvms_element_build_from_source

Break on OpenCLErrorBreak to debug.
BUILD LOG
Error returned by cvms_element_build_from_source
clBuildProgram() failed (-11) Program build failure
Error -11. Processing Aborted.
22:02:06 (1503): called boinc_finish

</stderr_txt>
]]>
17) Message boards : News : Collatz Back Online with Solo Collatz Only (Message 18418)
Posted 1436 days ago by zombie67 [MM]
Can you try setting the environment variable CL_LOG_ERRORS to stderr or stdout and see if that lets it report more detail about the problem? e.g. CL_LOG_ERRORS=stderr


Okay, I finally found the time to get to this. Sorry for the delay!

Does it help explain what is the issue?:

http://boinc.thesonntags.com/collatz/result.php?resultid=136057

Stderr output

<core_client_version>7.2.39</core_client_version>
<![CDATA[
<message>
process exited with code 245 (0xf5, -11)
</message>
<stderr_txt>
Collatz Conjecture v6.04 x86_64 for OpenCL
Based on the AMD Brook+ kernels by Gipsel
Platform: ADVANCED MICRO DEVICES
Device: 16915200
OpenCL context created
OpenCL command queue created
OpenCL program created
[CL_DEVICE_NOT_AVAILABLE] : OpenCL Error : Error: Build Program driver returned (518)
Break on OpenCLErrorBreak to debug.
OpenCL Warning : clBuildProgram failed: could not build program for 0x1021b00 (ATI Radeon HD 6630M) (err:-2)
Break on OpenCLWarningBreak to debug.
[CL_BUILD_ERROR] : OpenCL Build Error : Compiler build log:
Error returned by cvms_element_build_from_source

Break on OpenCLErrorBreak to debug.
[CL_INVALID_VALUE] : OpenCL Error : clGetProgramBuildInfo failed: If you pass a non-zero buffer size, you must pass a non-NULL buffer
Break on OpenCLErrorBreak to debug.
BUILD LOG

clBuildProgram() failed (-11) Program build failure
Error -11. Processing Aborted.
19:05:30 (577): called boinc_finish

</stderr_txt>
]]>
18) Message boards : News : Collatz Back Online with Solo Collatz Only (Message 18396)
Posted 1438 days ago by zombie67 [MM]
Thanks for the prefs fix!
19) Message boards : News : Collatz Back Online with Solo Collatz Only (Message 18390)
Posted 1438 days ago by zombie67 [MM]
Reminder: There is still no option to select ATI GPU in the preferences section. Just nvidia and intel GPUs.
20) Message boards : News : Collatz Back Online with Solo Collatz Only (Message 18376)
Posted 1439 days ago by zombie67 [MM]
I was wrong. I am GPU crunching on my intel HD 4000 in my mac mini! A first for me. Thanks!


Next 20

Main page · Your account · Message boards


Copyright © 2018 Jon Sonntag; All rights reserved.